pkg-autotools: don't disable dependency tracking if using <pkg>_OVERRIDE_SRCDIR
authorIgnacy Gawędzki <ignacy.gawedzki@green-communications.fr>
Wed, 1 Feb 2017 13:53:10 +0000 (14:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Mar 2017 21:48:04 +0000 (22:48 +0100)
Include the --disable-dependency-tracking option in <pkg>_CONFIGURE_CMDS
only on the condition that <pkg>_OVERRIDE_SRCDIR is empty. Dependency
tracking is very welcome while developing in order to properly rebuild
when calling make <pkg>-rebuild for instance.

Signed-off-by: Ignacy Gawędzki <ignacy.gawedzki@green-communications.fr>
package/pkg-autotools.mk

index f7b848888be114d3e8486ce8bbaf9865fc1b9847..e215382d069318f69e8b1d6372ff39f577d46701 100644 (file)
@@ -199,7 +199,7 @@ define $(2)_CONFIGURE_CMDS
                --disable-documentation \
                --with-xmlto=no \
                --with-fop=no \
-               --disable-dependency-tracking \
+               $$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
                --enable-ipv6 \
                $$(DISABLE_NLS) \
                $$(SHARED_STATIC_LIBS_OPTS) \
@@ -232,7 +232,7 @@ define $(2)_CONFIGURE_CMDS
                --disable-debug \
                --with-xmlto=no \
                --with-fop=no \
-               --disable-dependency-tracking \
+               $$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
                $$(QUIET) $$($$(PKG)_CONF_OPTS) \
        )
 endef