dialog: bump to version 1.2-20150125
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 21 Feb 2015 11:52:27 +0000 (08:52 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Feb 2015 13:07:00 +0000 (14:07 +0100)
And drop thread requirement, it's really not necessary.
For python-dialog that was already inherent in python itself.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dialog/Config.in
package/dialog/dialog.hash
package/dialog/dialog.mk
package/python-dialog/Config.in

index 929ab466aa2b692fdefc5aaea007d245d56f1b01..fc0e8fd51d4b5d8943678458dd15b1471f5e7386 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_DIALOG
        bool "dialog"
-       depends on BR2_TOOLCHAIN_HAS_THREADS # fork()
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_NCURSES
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
@@ -12,7 +11,3 @@ config BR2_PACKAGE_DIALOG
          of a script to interact with the user in a much friendlier manner.
 
          http://invisible-island.net/dialog/dialog.html
-
-comment "dialog needs a toolchain w/ threads"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
-       depends on BR2_USE_MMU
index 1ffbafbebc904dce32b1b6f9c9db5c1da2cd1d1c..75a79189c88758c1de1b612825b4b87471e9c5e5 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 d054766fba3dac828851f1c9852e5992eb824fd0a0dd26d87ee517242027bafc        dialog-1.2-20140911.tgz
+sha256 1d98ec7cc81f11f9019fa0b90f1afdaa86579cae1ce8869a6fd61deb9d4b887a        dialog-1.2-20150125.tgz
index 0ecbddbb8058a18f5f7c8e2bc6f4c7c1ff5a185b..f207f757041985a4b787302e053b16d69331bb9b 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-DIALOG_VERSION = 1.2-20140911
+DIALOG_VERSION = 1.2-20150125
 DIALOG_SOURCE = dialog-$(DIALOG_VERSION).tgz
 DIALOG_SITE = ftp://invisible-island.net/dialog
 DIALOG_CONF_OPTS = --with-ncurses --with-curses-dir=$(STAGING_DIR)/usr \
index 8dd3fdf4e7ff0e1b6b9481096453f849f988fb85..c1fdb23723c544820106be1881bde43e85f26c60 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_PYTHON_DIALOG
        bool "python-dialog"
        depends on BR2_PACKAGE_PYTHON
-       depends on BR2_TOOLCHAIN_HAS_THREADS # dialog
        depends on BR2_USE_MMU # dialog
        select BR2_PACKAGE_DIALOG
        help
@@ -9,7 +8,3 @@ config BR2_PACKAGE_PYTHON_DIALOG
          mostly-compatible programs.
 
          http://pythondialog.sourceforge.net/
-
-comment "python-dialog needs a toolchain w/ threads"
-       depends on BR2_USE_MMU && BR2_PACKAGE_PYTHON
-       depends on !BR2_TOOLCHAIN_HAS_THREADS