package/kodi: re-structure dependencies
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 11 Jul 2016 18:08:56 +0000 (20:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Jul 2016 12:24:28 +0000 (14:24 +0200)
Use one package per line to ease review of Kodi 17 version bump, where
10+ packages will be removed. This patch contains no code changes.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/kodi.mk

index 90c50c3ae167c02c63478825d2c83b04bd884bdf..8a3b0bfc5fbe95b87e052af9b946ec6a7fe09f72 100644 (file)
@@ -10,13 +10,54 @@ KODI_LICENSE = GPLv2
 KODI_LICENSE_FILES = LICENSE.GPL
 # needed for binary addons
 KODI_INSTALL_STAGING = YES
-KODI_DEPENDENCIES = host-gawk host-gettext host-gperf host-zip host-giflib \
-       host-libjpeg host-lzo host-nasm host-libpng host-swig
-KODI_DEPENDENCIES += boost bzip2 expat ffmpeg fontconfig freetype giflib jasper jpeg \
-       libass libcdio libcrossguid libcurl libdcadec libfribidi libgcrypt libmpeg2 \
-       libogg libplist libpng libsamplerate libsquish libvorbis libxml2 \
-       libxslt lzo ncurses openssl pcre python readline sqlite taglib tiff \
-       tinyxml yajl zlib
+KODI_DEPENDENCIES = \
+       boost \
+       bzip2 \
+       expat \
+       ffmpeg \
+       fontconfig \
+       freetype \
+       giflib \
+       host-gawk \
+       host-gettext \
+       host-giflib \
+       host-gperf \
+       host-libjpeg \
+       host-libpng \
+       host-lzo \
+       host-nasm \
+       host-swig \
+       host-zip \
+       jasper \
+       jpeg \
+       libass \
+       libcdio \
+       libcrossguid \
+       libcurl \
+       libdcadec \
+       libfribidi \
+       libgcrypt \
+       libmpeg2 \
+       libogg \
+       libplist \
+       libpng \
+       libsamplerate \
+       libsquish \
+       libvorbis \
+       libxml2 \
+       libxslt \
+       lzo \
+       ncurses \
+       openssl \
+       pcre \
+       python \
+       readline \
+       sqlite \
+       taglib \
+       tiff \
+       tinyxml \
+       yajl \
+       zlib
 
 KODI_CONF_ENV = \
        PYTHON_VERSION="$(PYTHON_VERSION_MAJOR)" \