package/ffmpeg: Add optional dependencies
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 17 Oct 2015 12:31:58 +0000 (14:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Oct 2015 14:29:20 +0000 (16:29 +0200)
Disable libcdio and libilbc since they are incompatible with ffmpeg.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index f3619706d9ed40b559def7f3466f6a6fc7f348c0..f28eed8639e4993253e25f80bec34923462b0a99 100644 (file)
@@ -50,9 +50,11 @@ FFMPEG_CONF_OPTS = \
        --disable-libopencore-amrnb \
        --disable-libopencore-amrwb \
        --disable-libopencv \
+       --disable-libcdio \
        --disable-libdc1394 \
        --disable-libfaac \
        --disable-libgsm \
+       --disable-libilbc \
        --disable-libnut \
        --disable-libopenjpeg \
        --disable-libschroedinger \
@@ -191,6 +193,13 @@ else
 FFMPEG_CONF_OPTS += --disable-bzlib
 endif
 
+ifeq ($(BR2_PACKAGE_FDK_AAC)$(BR2_PACKAGE_FFMPEG_NONFREE),yy)
+FFMPEG_CONF_OPTS += --enable-libfdk-aac
+FFMPEG_DEPENDENCIES += fdk-aac
+else
+FFMPEG_CONF_OPTS += --disable-libfdk-aac
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 # openssl isn't license compatible with GPL
 ifeq ($(BR2_PACKAGE_FFMPEG_GPL)x$(BR2_PACKAGE_FFMPEG_NONFREE),yx)
@@ -203,6 +212,20 @@ else
 FFMPEG_CONF_OPTS += --disable-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDCADEC),y)
+FFMPEG_CONF_OPTS += --enable-libdcadec
+FFMPEG_DEPENDENCIES += libdcadec
+else
+FFMPEG_CONF_OPTS += --disable-libdcadec
+endif
+
+ifeq ($(BR2_PACKAGE_LIBOPENH264),y)
+FFMPEG_CONF_OPTS += --enable-libopenh264
+FFMPEG_DEPENDENCIES += libopenh264
+else
+FFMPEG_CONF_OPTS += --disable-libopenh264
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 FFMPEG_DEPENDENCIES += libvorbis
 FFMPEG_CONF_OPTS += \