jq: new package
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 26 Sep 2013 01:09:55 +0000 (21:09 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Oct 2013 10:58:11 +0000 (11:58 +0100)
jq is like sed for JSON data - you can use it to slice and filter
and map and transform structured data with the same ease that sed,
awk, grep and friends let you play with text.

[Peter: fix license, add flex/bison deps, force c99]
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/jq/Config.in [new file with mode: 0644]
package/jq/jq.mk [new file with mode: 0644]

index 32be4d981fdab5c9db823bf1756a602b9f78a404..4c4da5119d77f0193b1249580cdadcafe10ebb9c 100644 (file)
@@ -108,6 +108,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/grep/Config.in"
 endif
 source "package/intltool/Config.in"
+source "package/jq/Config.in"
 source "package/libtool/Config.in"
 source "package/m4/Config.in"
 source "package/make/Config.in"
diff --git a/package/jq/Config.in b/package/jq/Config.in
new file mode 100644 (file)
index 0000000..9329b2f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_JQ
+       bool "jq"
+       help
+         jq is like sed for JSON data - you can use it to slice and filter
+         and map and transform structured data with the same ease that sed,
+         awk, grep and friends let you play with text.
+
+         http://stedolan.github.io/jq/
diff --git a/package/jq/jq.mk b/package/jq/jq.mk
new file mode 100644 (file)
index 0000000..8d4f24f
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# jq
+#
+################################################################################
+
+JQ_VERSION = jq-1.3
+JQ_SITE = http://github.com/stedolan/jq/tarball/$(JQ_VERSION)
+JQ_AUTORECONF = YES
+JQ_DEPENDENCIES = host-flex host-bison
+JQ_LICENSE = MIT (code), CC-BY-3.0 (documentation)
+JQ_LICENSE_FILES = COPYING
+
+# uses c99 specific features
+JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
+
+$(eval $(autotools-package))