Enable e300c2, e300c3 and e500mc powerpc optimizations
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 8 Apr 2010 02:00:28 +0000 (23:00 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 8 Apr 2010 11:16:13 +0000 (13:16 +0200)
Closes #1513

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
target/Config.in.arch
toolchain/uClibc/uclibc.mk

diff --git a/CHANGES b/CHANGES
index 2d8d2e8c1b5c25fe44fecb9150c3417898bcd1eb..4564aaa97f614cf0a039a5fef2ff3a6f2f14e7dd 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,8 @@
 
        Toolchain: uClibc 0.9.30.3 / 0.9.31, older 0.9.30.x removed.
        2.6.33 kernel headers, binutils 2.20.1, removed broken nios2
-       support, improved external toolchain support.
+       support, ppc e300cX/e500mc support, improved external
+       toolchain support.
 
        X.org updated to 7.5.
 
@@ -48,6 +49,7 @@
        #1447: Package installation on target with debug symbols is broken
        #1459: Misc QA fixes
        #1489: radvd update to 1.6
+       #1513: Enable powerpc e300c2, e300c3 and e500mc optimization
 
 2010.02, Release February 26th, 2010:
 
index 26f7aa5db722ff2055bf469fba13b5df20048bbd..1de679f99992e0d35a7cacda50a06e244636c495 100644 (file)
@@ -490,6 +490,15 @@ config BR2_powerpc_970
        bool "970"
 config BR2_powerpc_8540
        bool "8540"
+comment "e300c2 needs gcc >= 4.4.x"
+config BR2_powerpc_e300c2
+       bool "e300c2"
+comment "e300c3 needs gcc >= 4.4.x"
+config BR2_powerpc_e300c3
+       bool "e300c3"
+comment "e500mc needs gcc >= 4.4.x"
+config BR2_powerpc_e500mc
+       bool "e500mc"
 endchoice
 
 config BR2_ARCH
@@ -648,6 +657,9 @@ config BR2_GCC_TARGET_TUNE
        default 860             if BR2_powerpc_860
        default 970             if BR2_powerpc_970
        default 8540            if BR2_powerpc_8540
+       default e300c2          if BR2_powerpc_e300c2
+       default e300c3          if BR2_powerpc_e300c3
+       default e500mc          if BR2_powerpc_e500mc
        default v7              if BR2_sparc_v7
        default cypress         if BR2_sparc_cypress
        default v8              if BR2_sparc_v8
index 3e69770297fedc4cd9776778ff9e16c28f8cc599..ddeb3951a753496b4b3aa1e76762b60e7ea515cf 100644 (file)
@@ -232,6 +232,12 @@ ifeq ($(UCLIBC_TARGET_ARCH),sparc)
 endif
 ifeq ($(UCLIBC_TARGET_ARCH),powerpc)
 ifeq ($(BR2_powerpc_8540),y)
+       TARGET_POWERPC_CORE_E500:=y
+endif
+ifeq ($(BR2_powerpc_e500mc),y)
+       TARGET_POWERPC_CORE_E500:=y
+endif
+ifeq ($(TARGET_POWERPC_CORE_E500),y)
        /bin/echo "# CONFIG_CLASSIC is not set" >> $(UCLIBC_DIR)/.oldconfig
        /bin/echo "CONFIG_E500=y" >> $(UCLIBC_DIR)/.oldconfig
 else