package/gcc: wrap gfortran
authorSamuel Martin <s.martin49@gmail.com>
Fri, 1 Jul 2016 16:29:07 +0000 (18:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 20:55:05 +0000 (22:55 +0200)
gfortran supports all options supported by gcc, so it can and should be called
via the toolchain wrapper.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index 6e1c02de93422dafe80e2a2953e82f6e36b39b8d..a796f473ad25f3fd0c59fe23a5d6e8192e76156c 100644 (file)
@@ -265,6 +265,8 @@ endif # BR2_CCACHE
 # used. However, we should not add the toolchain wrapper for them, and they
 # match the *cc-* pattern. Therefore, an additional case is added for *-ar,
 # *-ranlib and *-nm.
+# According to gfortran manpage, it supports all options supported by gcc, so
+# add gfortran to the list of the program called via the Buildroot wrapper.
 # Avoid that a .br_real is symlinked a second time.
 # Also create <arch>-linux-<tool> symlinks.
 define HOST_GCC_INSTALL_WRAPPER_AND_SIMPLE_SYMLINKS
@@ -276,7 +278,7 @@ define HOST_GCC_INSTALL_WRAPPER_AND_SIMPLE_SYMLINKS
                *-ar|*-ranlib|*-nm) \
                        ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
                        ;; \
-               *cc|*cc-*|*++|*++-*|*cpp) \
+               *cc|*cc-*|*++|*++-*|*cpp|*-gfortran) \
                        rm -f $$i.br_real; \
                        mv $$i $$i.br_real; \
                        ln -sf toolchain-wrapper $$i; \