gcc: improve configuration for snapshot versions
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 10:59:44 +0000 (11:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 22:54:44 +0000 (23:54 +0100)
Make the selection of a snapshot version a normal gcc version choice,
and make sure BR2_GCC_VERSION is properly defined.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/Config.in
toolchain/gcc/Makefile.in

index 07e42a6da630d09819a41ca8b59af6c1e4043e9b..10cb841a1a6143620c4f56fc7fd12ec78c22a14e 100644 (file)
@@ -55,11 +55,11 @@ choice
        config BR2_GCC_VERSION_4_4_X
                depends on !BR2_avr32 && !BR2_nios2
                bool "gcc 4.4.x"
-endchoice
 
-config BR2_GCC_IS_SNAP
-       depends on !BR2_avr32
-       bool
+       config BR2_GCC_VERSION_SNAP
+               depends on !BR2_avr32 && !BR2_nios2
+               bool "gcc snapshot"
+endchoice
 
 config BR2_GCC_SUPPORTS_SYSROOT
        bool
@@ -72,7 +72,7 @@ config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
 config BR2_GCC_SNAP_DATE
        string "GCC snapshot date"
        default "20070921"
-       depends on BR2_GCC_IS_SNAP
+       depends on BR2_GCC_VERSION_SNAP
        help
          Enter snapshot date to use for gcc.  Format is:
          YYYYMMDD
@@ -89,6 +89,7 @@ config BR2_GCC_VERSION
        default "4.3.3"     if BR2_GCC_VERSION_4_3_3
        default "4.3.4"     if BR2_GCC_VERSION_4_3_4
        default "4.4.2"     if BR2_GCC_VERSION_4_4_X
+       default $BR2_GCC_SNAP_DATE if BR2_GCC_VERSION_SNAP
 
 config BR2_TOOLCHAIN_SYSROOT
        bool "Enable toolchain with --sysroot support"
index e92ecbc7b5b0362e74aea6a43ee9d216a5f2fa0c..c3e21cf35245cc1b5dbab73f778fef4580792567 100644 (file)
@@ -8,7 +8,7 @@ GCC_VERSION:=$(call qstrip,$(BR2_GCC_VERSION))
 TARGET_OPTIMIZATION:=$(call qstrip,$(BR2_TARGET_OPTIMIZATION))
 EXTRA_GCC_CONFIG_OPTIONS:=$(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
 
-ifeq ($(call qstrip,$(BR2_GCC_IS_SNAP)),y)
+ifeq ($(call qstrip,$(BR2_GCC_VERSION_SNAP)),y)
 GCC_SNAP_DATE:=$(call qstrip,$(BR2_GCC_SNAP_DATE))
 else
 GCC_SNAP_DATE:=