package/libblockdev: add support for loop plugin
authorAdam Duskett <Aduskett@gmail.com>
Sat, 25 Jul 2020 23:06:11 +0000 (16:06 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 19:45:58 +0000 (21:45 +0200)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libblockdev/Config.in
package/libblockdev/libblockdev.mk

index 8ef7247262f32d5a5a58728f3b81bc2f140e2589..9f7f401dd336deffd98029b3c95e708f73bbaff5 100644 (file)
@@ -33,6 +33,9 @@ config BR2_PACKAGE_LIBBLOCKDEV_FS
 comment "filesystem plugin needs a toolchain w/ locale"
        depends on !BR2_ENABLE_LOCALE
 
+config BR2_PACKAGE_LIBBLOCKDEV_LOOP
+       bool "loop"
+
 endif
 
 comment "libblockdev needs udev /dev management and a toolchain w/ wchar, threads, dynamic library"
index 2b111df82b0c34dd43063d12a5870bde1cd7e8fd..9216fc9932e2f1af73e3b4a19df0dedfebafb964 100644 (file)
@@ -22,7 +22,6 @@ LIBBLOCKDEV_CONF_OPTS = \
        --without-dmraid \
        --without-escrow \
        --without-kbd \
-       --without-loop \
        --without-lvm \
        --without-lvm_dbus \
        --without-mdraid \
@@ -50,4 +49,10 @@ else
 LIBBLOCKDEV_CONF_OPTS += --without-fs
 endif
 
+ifeq ($(BR2_PACKAGE_LIBBLOCKDEV_LOOP),y)
+LIBBLOCKDEV_CONF_OPTS += --with-loop
+else
+LIBBLOCKDEV_CONF_OPTS += --without-loop
+endif
+
 $(eval $(autotools-package))