package/pcre2: add JIT support option
authorArtem Panfilov <panfilov.artyom@gmail.com>
Fri, 15 Feb 2019 23:20:58 +0000 (02:20 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 13 Apr 2019 19:45:32 +0000 (21:45 +0200)
Add JIT support option.

Signed-off-by: Artem Panfilov <panfilov.artyom@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pcre2/Config.in
package/pcre2/pcre2.mk

index bb576c75a1f2210bd31a1b293a2cbb6db950fbbe..007dd960c6c32d69a076a9a360cb5672fed611f9 100644 (file)
@@ -23,4 +23,12 @@ config BR2_PACKAGE_PCRE2_32
          This option builds the 32-bits pcre2 library, i.e
          'libpcre2-32'
 
+config BR2_PACKAGE_PCRE2_JIT
+       bool "enable JIT support"
+       depends on BR2_i386 || BR2_x86_64 || BR2_arm  || BR2_armeb || \
+               BR2_aarch64 || BR2_mips || BR2_mipsel || \
+               BR2_mips64 || BR2_mips64el || BR2_powerpc || BR2_sparc
+       help
+         This option enables JIT support
+
 endif
index ee3cacb9aaeb1fa476b2c612025e896ca88b9f65..6d103c2b9b6e492fcd90dfb28a791b48240d3d9d 100644 (file)
@@ -16,6 +16,12 @@ PCRE2_CONF_OPTS += --enable-pcre2-8
 PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_16),--enable-pcre2-16,--disable-pcre2-16)
 PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_32),--enable-pcre2-32,--disable-pcre2-32)
 
+ifeq ($(BR2_PACKAGE_PCRE2_JIT),y)
+PCRE2_CONF_OPTS += --enable-jit
+else
+PCRE2_CONF_OPTS += --disable-jit
+endif
+
 # disable fork usage if not available
 ifeq ($(BR2_USE_MMU),)
 PCRE2_CONF_OPTS += --disable-pcre2grep-callout