package/gettext-tiny: drop dependency of host-variant on libiconv
authorVadim Kochan <vadim4j@gmail.com>
Tue, 9 Apr 2019 13:55:04 +0000 (16:55 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Apr 2019 10:01:27 +0000 (12:01 +0200)
The host variant of gettext-tiny incorrectly has a dependency on the
target libiconv. Not only this is wrong (a host package cannot use a
target library), but it also causes a circular dependencies:
host-gettext-tiny is needed as part of the toolchain build in some
configurations, and all target packages depend on the toolchain being
available.

For host packages, we assume that iconv functionnality is provided by
the host system, so there is no host-libiconv package.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Reviewed-by: Alexey Brodkin <abrokdin@synopsys.com>
[Thomas: rework commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gettext-tiny/gettext-tiny.mk

index 4fa014e8ddaa22c96294888ad949af66581cfb2a..87e90bcc70c621a237e2cb5e130b33cc36471f86 100644 (file)
@@ -49,10 +49,6 @@ define HOST_GETTEXT_TINY_COPY_EXTRA_FILES
 endef
 HOST_GETTEXT_TINY_POST_PATCH_HOOKS += HOST_GETTEXT_TINY_COPY_EXTRA_FILES
 
-ifeq ($(BR2_ENABLE_LOCALE),)
-HOST_GETTEXT_TINY_DEPENDENCIES = libiconv
-endif
-
 define HOST_GETTEXT_TINY_BUILD_CMDS
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
                $(HOST_CONFIGURE_OPTS) \