libcurl: disable curldebug
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 23 Apr 2015 20:01:36 +0000 (17:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Apr 2015 20:59:05 +0000 (22:59 +0200)
curldebug is a more advanced form of debugging for curl which audits
source code with the checksource.pl tool, and treats warnings as errors.
Normally users won't want/need this so disable it since it leads to
failed builds when debug info is enabled (which is what people normally
want).
When buildroot does --enable-debug curl inherently enables curldebug too.

Solves bug #8041.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcurl/libcurl.mk

index acb2b42b9d4783033759933a42f9108e7961c29d..33903997cb13601f44380c09cf67f33b6f017085 100644 (file)
@@ -20,7 +20,7 @@ LIBCURL_INSTALL_STAGING = YES
 # probably almost never used. See
 # http://curl.haxx.se/docs/manpage.html#--ntlm.
 LIBCURL_CONF_OPTS = --disable-verbose --disable-manual --disable-ntlm-wb \
-       --enable-hidden-symbols --with-random=/dev/urandom
+       --enable-hidden-symbols --with-random=/dev/urandom --disable-curldebug
 LIBCURL_CONFIG_SCRIPTS = curl-config
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)