package/openjdk: copy all directories and files when installing
authorAdam Duskett <Aduskett@gmail.com>
Sat, 18 Apr 2020 19:07:00 +0000 (12:07 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 21 Apr 2020 21:24:29 +0000 (23:24 +0200)
Several directories and files are currently not installed during the
target installation, these include:
  - conf
    Several configuration files, including security configuration files which
    may be necessary for running various java applications.

  - legal
    This directory contains legal notices that some java applications may
    require, as they may print legal information and will throw exceptions at
    runtime if the legal files are not present on the system.

  - release
    This file contains a list of modules included in the image.

Because these directories take up less than of megabyte extra, it is not an
issue to install all of them.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Reviewed-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Tested-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/openjdk/openjdk.mk

index 963c2bbebeee87b9306b04cd31f80aa2b6e0f3b7..ffa62dd10db24ada1632becca22fc76c93278e5e 100644 (file)
@@ -123,9 +123,7 @@ endef
 # which makes manual installation necessary.
 define OPENJDK_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)$(OPENJDK_INSTALL_BASE)
-       cp -dpfr $(@D)/build/linux-*-release/images/jre/bin/ \
-               $(TARGET_DIR)$(OPENJDK_INSTALL_BASE)/
-       cp -dpfr $(@D)/build/linux-*-release/images/jre/lib/ \
+       cp -dpfr $(@D)/build/linux-*-release/images/jre/* \
                $(TARGET_DIR)$(OPENJDK_INSTALL_BASE)/
        cd $(TARGET_DIR)/usr/bin && ln -snf ../..$(OPENJDK_INSTALL_BASE)/bin/* .
 endef