gnupg: disable assembly optimization for coldfire
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 31 Jul 2016 08:27:19 +0000 (10:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 5 Aug 2016 07:17:33 +0000 (09:17 +0200)
Fixes:
http://autobuild.buildroot.net/results/d25425cff055a14b9285cefb0775bc138eb2f914/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gnupg/gnupg.mk

index 8893a1cc687e7f04dc4642def94f46a7a385a132..54f4d97365a9e7f2c4d0e2adc4701493e3a2b9bd 100644 (file)
@@ -13,6 +13,11 @@ GNUPG_DEPENDENCIES = zlib ncurses $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 GNUPG_CONF_ENV = ac_cv_sys_symbol_underscore=no
 GNUPG_CONF_OPTS = --disable-rpath --enable-minimal --disable-regex
 
+# gnupg doesn't support assembly for coldfire
+ifeq ($(BR2_m68k_cf),y)
+GNUPG_CONF_OPTS += --disable-asm
+endif
+
 ifeq ($(BR2_PACKAGE_BZIP2),y)
 GNUPG_CONF_OPTS += --enable-bzip2
 GNUPG_DEPENDENCIES += bzip2