python: bump to version 2.7.8
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Jul 2014 10:42:38 +0000 (12:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Jul 2014 11:56:42 +0000 (13:56 +0200)
The different patches are just refreshed to apply without fuzz, there
are no changes/conflicts.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
21 files changed:
package/python/python-004-sysconfigdata-install-location.patch
package/python/python-006-cross-compile-getaddrinfo.patch
package/python/python-007-disable-extensions.patch
package/python/python-009-no-termcap-host-path.patch
package/python/python-010-fix-python-config.patch
package/python/python-100-optional-test-modules.patch
package/python/python-101-optional-pydoc.patch
package/python/python-102-optional-2to3.patch
package/python/python-103-optional-sqlite.patch
package/python/python-104-optional-tk.patch
package/python/python-105-optional-curses.patch
package/python/python-106-optional-expat.patch
package/python/python-107-optional-codecs-cjk.patch
package/python/python-108-optional-nis.patch
package/python/python-109-optional-unicodedata.patch
package/python/python-110-optional-db.patch
package/python/python-111-optional-ssl.patch
package/python/python-112-optional-bzip2.patch
package/python/python-113-optional-zlib.patch
package/python/python-114-remove-idle-editor.patch
package/python/python.mk

index 2a5e4f4582cb75d75c8a43d655ad3adc5469367c..e053de31928dcfd0c6c9b1609cb6d066ac6578ed 100644 (file)
@@ -52,7 +52,7 @@ Index: b/Makefile.pre.in
        @for d in $(LIBSUBDIRS); \
        do \
                a=$(srcdir)/Lib/$$d; \
-@@ -1303,7 +1311,7 @@
+@@ -1304,7 +1312,7 @@
                Modules/Setup Modules/Setup.local Modules/Setup.config \
                Modules/ld_so_aix Modules/python.exp Misc/python.pc
        -rm -f python*-gdb.py
index b16c7e9814f95e7064d54f7c366821320da822ec..ff050953b4cfb8ce236fb562fd410668af8b6dea 100644 (file)
@@ -2,7 +2,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3330,7 +3330,7 @@
+@@ -3343,7 +3343,7 @@
  
  AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
  
index 10b0a7c0469379764085bb80341f56a63160a6eb..40ed6df3bf7571ec6dd87361dcd8d4243dd46638 100644 (file)
@@ -33,7 +33,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2268,6 +2268,8 @@
+@@ -2281,6 +2281,8 @@
  
  AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
  
index 7df8a32a00f0f3b1e42661983eacabffd7560e99..fadc7b32383bc12c311bd7980eaaf7a994a3d958 100644 (file)
@@ -7,7 +7,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -760,12 +760,9 @@
+@@ -762,12 +762,9 @@
                  pass # Issue 7384: Already linked against curses or tinfo.
              elif curses_library:
                  readline_libs.append(curses_library)
index 9e35de68d3ec976ac60051b8e6d21fb6bb367561..97ff157bc2e84aa1e2166d5e37d045355c2cedd5 100644 (file)
@@ -26,7 +26,7 @@ Index: b/configure.ac
    case $ac_sys_system in
      CYGWIN*)
            BLDLIBRARY='$(LIBRARY)'
-@@ -1909,6 +1911,9 @@
+@@ -1915,6 +1917,9 @@
  AC_SUBST(BLDSHARED)
  AC_SUBST(CCSHARED)
  AC_SUBST(LINKFORSHARED)
@@ -36,7 +36,7 @@ Index: b/configure.ac
  # SO is the extension of shared libraries `(including the dot!)
  # -- usually .so, .sl on HP-UX, .dll on Cygwin
  AC_MSG_CHECKING(SO)
-@@ -4550,7 +4555,7 @@
+@@ -4563,7 +4568,7 @@
  AC_MSG_RESULT(done)
  
  # generate output files
@@ -91,7 +91,7 @@ Index: b/Makefile.pre.in
        @if [ -s Modules/python.exp -a \
                "`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
                echo; echo "Installing support files for building shared extension modules on AIX:"; \
-@@ -1311,6 +1313,7 @@
+@@ -1312,6 +1314,7 @@
                config.cache config.log pyconfig.h Modules/config.c
        -rm -rf build platform
        -rm -rf $(PYTHONFRAMEWORKDIR)
index ff9c914581bbe2f081fa0f7f555f9d467d09dd79..33bc5f8a58e187f5647cd210843a2864aa6e86f0 100644 (file)
@@ -78,7 +78,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2612,6 +2612,12 @@
+@@ -2625,6 +2625,12 @@
  fi
  
  
index 7518b5e664c0350096cbcc32f7cc74733ac75b77..cb8631affd88a7e30ae84e0c68f406b1be876347 100644 (file)
@@ -40,7 +40,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2611,6 +2611,11 @@
+@@ -2624,6 +2624,11 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
@@ -56,7 +56,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2217,6 +2217,12 @@
+@@ -2219,6 +2219,12 @@
      # turn off warnings when deprecated modules are imported
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
@@ -69,7 +69,7 @@ Index: b/setup.py
      setup(# PyPI Metadata (PEP 301)
            name = "Python",
            version = sys.version.split()[0],
-@@ -2237,9 +2243,7 @@
+@@ -2239,9 +2245,7 @@
            ext_modules=[Extension('_struct', ['_struct.c'])],
  
            # Scripts to install
index 3503f8c0c0cc204633d1516ebed539ad7129d206..0d23ca3e89de34c8e38f21455391915a37a2b172 100644 (file)
@@ -52,7 +52,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2623,6 +2623,12 @@
+@@ -2636,6 +2636,12 @@
        AS_HELP_STRING([--disable-test-modules], [disable test modules]),
        [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
  
@@ -69,7 +69,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2218,10 +2218,11 @@
+@@ -2220,10 +2220,11 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
index a75acc82581be3f7c92b6696d1adc19d0262a9ce..1e175300429b3243eabaacf3f6e57c91e8f835bb 100644 (file)
@@ -12,7 +12,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2611,6 +2611,15 @@
+@@ -2624,6 +2624,15 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
index 2e469ab481f2f80ce821101ab1ea3e364d407974..298c91d3b151622e7d7900947bce6a2a5c35e532 100644 (file)
@@ -48,7 +48,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2620,6 +2620,15 @@
+@@ -2633,6 +2633,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index 384cad3e4788d13c0e8cfef3d319c089da7ceb8e..00f226632988d8ca4aef6fff43b65412192fb6fc 100644 (file)
@@ -36,7 +36,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2629,6 +2629,15 @@
+@@ -2642,6 +2642,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
  fi
  
index c1de887f7451cb0c4f68556ef5b8818856a88630..d80dee4a534e68e9da6f30c530720b9cf5b9e9f4 100644 (file)
@@ -43,7 +43,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2276,13 +2276,21 @@
+@@ -2289,13 +2289,21 @@
  AC_SUBST(DISABLED_EXTENSIONS)
  
  # Check for use of the system expat library
@@ -74,7 +74,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -1469,7 +1469,7 @@
+@@ -1471,7 +1471,7 @@
          #
          # More information on Expat can be found at www.libexpat.org.
          #
index ad1d41f398844b09ac3e8c271e40f9ea6c2d878e..132b4bd8ace9ef08d7d669cb31f354f25efcec54 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2628,6 +2628,12 @@
+@@ -2641,6 +2641,12 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index bac49ff4b12650e2a90a7c5cc9960cbd415e93a4..12aa2f1450b35779247a72867247f2547395732a 100644 (file)
@@ -13,7 +13,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2634,6 +2634,12 @@
+@@ -2647,6 +2647,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
          fi])
  
index af9a28eeb4ba9fa1d2572ac73c86a2bfbc8e3fa2..99a0daacf6fdd8487ace4f3221c2c347cb9b7253 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2640,6 +2640,12 @@
+@@ -2653,6 +2653,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index ff1979e4b1d1c306b92e4660555e9edac1810182..baee963714d0a7ff8a39bd39a1ed2c8971dba782 100644 (file)
@@ -49,7 +49,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2640,6 +2640,28 @@
+@@ -2653,6 +2653,28 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index cde6bb69d056c05eb3cbabe2e378192a80b08236..5b2074758672940e8a4891e5a0b915b43210dbc7 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2640,6 +2640,12 @@
+@@ -2653,6 +2653,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index 1b139bfc2667c090034b7fdbd1aa12acffd492a4..eeb330316778b7b398d0b00a8da42672f6d090c7 100644 (file)
@@ -9,7 +9,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2646,6 +2646,12 @@
+@@ -2659,6 +2659,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
          fi])
  
index e98265fbb8e2a09f87e5a54a966a5c6ed3335d3f..b93c9836b8c34ac27f028f4208ef15ee76534e33 100644 (file)
@@ -9,7 +9,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2652,6 +2652,12 @@
+@@ -2665,6 +2665,12 @@
              DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
           fi])
  
index 0f7367719dca86b21f29f60357a41170336b8084..9aba15c9b7ce33d67414c72ace77b9b78b7bf09c 100644 (file)
@@ -32,7 +32,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2218,7 +2218,7 @@
+@@ -2220,7 +2220,7 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
index 532e120a4b5e8a893d29ed80ac68ba38a14e64cb..cb54e3e9654efbf85264e952937c5ec465297c0e 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON_VERSION_MAJOR = 2.7
-PYTHON_VERSION       = $(PYTHON_VERSION_MAJOR).7
+PYTHON_VERSION       = $(PYTHON_VERSION_MAJOR).8
 PYTHON_SOURCE        = Python-$(PYTHON_VERSION).tar.xz
 PYTHON_SITE          = http://python.org/ftp/python/$(PYTHON_VERSION)
 PYTHON_LICENSE       = Python software foundation license v2, others