gcc: use BR2_EXTRA_GCC_CONFIG_OPTIONS in gcc-initial and gcc-intermediate
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 13 Jul 2013 22:27:24 +0000 (00:27 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 14 Jul 2013 20:07:38 +0000 (22:07 +0200)
When refactoring the internal toolchain backend logic, the code was
changed to pass the custom configure options given through
BR2_EXTRA_GCC_CONFIG_OPTIONS only for the gcc final pass, with the
idea that we're only interested by user customization for the final
compiler.

However, the beaglebone_defconfig was passing --with-float=hard
--with-fpu=vfpv3-d16 as BR2_EXTRA_GCC_CONFIG_OPTIONS, and since the
refactoring, it was causing build failures of the beaglebone_defconfig
(with messages saying that Busybox is built to use VFP arguments, but
libc/libm are not). This is due to the fact that the gcc intermediate,
which is used to build the C library, wasn't built to generate hard
float, while the final compiler was generating hard float.

So, we get back to the original situation where the options in
BR2_EXTRA_GCC_CONFIG_OPTIONS are passed to all of the compiler
passes. Of course, the specific case of hard float will be fixed by
following patches in this area, but the idea still remains: the three
gcc should have the same options, if those options affected the ABI of
the generated code.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gcc/Config.in.host
package/gcc/gcc-initial/gcc-initial.mk
package/gcc/gcc-intermediate/gcc-intermediate.mk

index 0836f9f64084372f40b6ada435e849f189815235..a529d14c2c1a70c6515d1f115783e3e704f0212b 100644 (file)
@@ -88,7 +88,9 @@ config BR2_EXTRA_GCC_CONFIG_OPTIONS
        string "Additional gcc options"
        default ""
        help
-         Any additional gcc configure options you may want to include....
+         Any additional gcc configure options you may want to
+         include. Those options are applied for all of the gcc
+         initial, gcc intermediate and gcc final passes.
 
 config BR2_INSTALL_OBJC
        bool "Build/install Objective-C compiler and runtime?"
index 05c956abcbf4a481d74d3f9c654257d4d8870abd..e4684194523c2adf826c2742d209c99ee57d1a23 100644 (file)
@@ -31,7 +31,8 @@ HOST_GCC_INITIAL_CONF_OPT = \
        --without-headers \
        --with-newlib \
        --disable-largefile \
-       --disable-nls
+       --disable-nls \
+       $(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
 
 HOST_GCC_INITIAL_MAKE_OPT = all-gcc
 HOST_GCC_INITIAL_INSTALL_OPT = install-gcc
index 5460000976da5726be3de67792dd2253849d4112..a6660256d7e9d24f0d3b9ad07ca63f865aae57a1 100644 (file)
@@ -30,7 +30,8 @@ HOST_GCC_INTERMEDIATE_CONF_OPT = \
        $(HOST_GCC_COMMON_CONF_OPT) \
        --enable-languages=c \
        --disable-largefile \
-       --disable-nls
+       --disable-nls \
+       $(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
 
 HOST_GCC_INTERMEDIATE_MAKE_OPT = all-gcc
 ifeq ($(BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE),y)