package/linux-tools: add support for pcitest tool
authorGustavo Pimentel <gustavo.pimentel@synopsys.com>
Tue, 13 Nov 2018 05:55:53 +0000 (06:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 13 Nov 2018 19:58:05 +0000 (20:58 +0100)
Add support for selection and compiling the pcitest tool on buildroot.

This tool is available to be compiled since kernel 4.20.

Signed-off-by: Gustavo Pimentel <gustavo.pimentel@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linux-tools/Config.in
package/linux-tools/linux-tool-pci.mk.in [new file with mode: 0644]

index 349dc6bf0ddd96969aabec8359134d350e84eb22..f4199fd618b21fad9783658419d57c16d3d01d80 100644 (file)
@@ -34,6 +34,15 @@ config BR2_PACKAGE_LINUX_TOOLS_IIO
 
          These tools are available only from kernel version 4.7.
 
+config BR2_PACKAGE_LINUX_TOOLS_PCI
+       bool "pci"
+       select BR2_PACKAGE_LINUX_TOOLS
+       help
+         pcitest is a tool for testing capabilities related to a
+         PCI Endpoint (only works with specific Endpoints).
+
+         These tools are available only from kernel version 4.20.
+
 config BR2_PACKAGE_LINUX_TOOLS_PERF
        bool "perf"
        select BR2_PACKAGE_LINUX_TOOLS
diff --git a/package/linux-tools/linux-tool-pci.mk.in b/package/linux-tools/linux-tool-pci.mk.in
new file mode 100644 (file)
index 0000000..4ef0368
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# pci
+#
+################################################################################
+
+LINUX_TOOLS += pci
+
+PCI_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
+
+define PCI_BUILD_CMDS
+       $(Q)if ! grep install $(LINUX_DIR)/tools/pci/Makefile >/dev/null 2>&1 ; then \
+               echo "Your kernel version is too old and does not have install section in the pci tools." ; \
+               echo "At least kernel 4.20 must be used." ; \
+               exit 1 ; \
+       fi
+
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/pci \
+               $(PCI_MAKE_OPTS)
+endef
+
+define PCI_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/pci \
+               $(PCI_MAKE_OPTS) \
+               DESTDIR=$(TARGET_DIR) \
+               install
+endef