pkg-download.mk: fix multiple matches in shallow clone test
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 6 Dec 2012 16:37:07 +0000 (16:37 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 9 Dec 2012 20:46:40 +0000 (21:46 +0100)
Move the git reference directly to git-ls-remote rather than
piping the output to grep, to help avoid reporting partial
matches rather than the actual requested reference.  Also,
add quotes to protest "test" from failing when multiple
strings are reported.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-download.mk

index ea01b053067222139c74a7e729d9b69bc5205a82..1705fcd8edefbaeaed8aa5404e26464e5af9aff5 100644 (file)
@@ -82,7 +82,7 @@ domainseparator=$(if $(1),$(1),/)
 define DOWNLOAD_GIT
        test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
        (pushd $(DL_DIR) > /dev/null && \
-        ((test `git ls-remote  $($(PKG)_SITE) | cut -f 2- | grep $($(PKG)_DL_VERSION)` && \
+        ((test "`git ls-remote $($(PKG)_SITE) $($(PKG)_DL_VERSION)`" && \
           echo "Doing shallow clone" && \
           $(GIT) clone --depth 1 -b $($(PKG)_DL_VERSION) --bare $($(PKG)_SITE) $($(PKG)_BASE_NAME)) || \
          (echo "Doing full clone" && \