mplayer: Fix external libdvdread and libdvdnav support
authorValentine Barshak <gvaxon@gmail.com>
Wed, 26 Sep 2012 09:34:51 +0000 (09:34 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Oct 2012 21:26:56 +0000 (23:26 +0200)
This sets paths to dvdread-config and dvdnav-config,
and configuration options to enable external libdvdread
and libdvdnav support.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/mplayer/mplayer.mk

index 05120bf780ea1ce054f5031c5570f26a040c0653..9ff4b8a62bd0f27b1b578b6368c336076e17bf5d 100644 (file)
@@ -42,6 +42,21 @@ else
 MPLAYER_CONF_OPTS += --disable-freetype
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
+MPLAYER_CONF_OPTS +=  \
+       --enable-dvdread \
+       --disable-dvdread-internal \
+       --with-dvdread-config=$(STAGING_DIR)/usr/bin/dvdread-config
+MPLAYER_DEPENDENCIES += libdvdread
+endif
+
+ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
+MPLAYER_CONF_OPTS +=  \
+       --enable-dvdnav \
+       --with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
+MPLAYER_DEPENDENCIES += libdvdnav
+endif
+
 ifeq ($(BR2_PACKAGE_MPLAYER_MPLAYER),y)
 MPLAYER_CONF_OPTS += --enable-mplayer
 else