musepack: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 18 Jan 2011 16:54:38 +0000 (13:54 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Jan 2011 20:29:47 +0000 (21:29 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/Config.in
package/multimedia/musepack/Config.in [new file with mode: 0644]
package/multimedia/musepack/musepack.mk [new file with mode: 0644]

index 16d747166553dbbbc9438d05da8ffa708adbf5b3..14c4145fd97356e7c3716c80e97269c8bfc9af31 100644 (file)
@@ -30,6 +30,7 @@ source "package/multimedia/libvorbis/Config.in"
 source "package/multimedia/madplay/Config.in"
 source "package/multimedia/mpg123/Config.in"
 source "package/multimedia/mplayer/Config.in"
+source "package/multimedia/musepack/Config.in"
 source "package/multimedia/speex/Config.in"
 source "package/multimedia/swfdec/Config.in"
 source "package/multimedia/festival/Config.in"
diff --git a/package/multimedia/musepack/Config.in b/package/multimedia/musepack/Config.in
new file mode 100644 (file)
index 0000000..2a966a4
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_MUSEPACK
+       bool "musepack"
+       select BR2_PACKAGE_LIBCUEFILE
+       select BR2_PACKAGE_LIBREPLAYGAIN
+       help
+         Musepack is an audio compression format with a strong emphasis
+         on high quality. It's not lossless, but it is designed
+         for transparency, so that you won't be able to hear differences
+         between the original wave file and the much smaller MPC file.
+
+         http://www.musepack.net/
diff --git a/package/multimedia/musepack/musepack.mk b/package/multimedia/musepack/musepack.mk
new file mode 100644 (file)
index 0000000..34581b6
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# musepack
+#
+################################################################################
+
+MUSEPACK_VERSION =  r435
+MUSEPACK_SITE = http://files.musepack.net/source
+MUSEPACK_SOURCE = musepack_src_$(MUSEPACK_VERSION).tar.gz
+MUSEPACK_DEPENDENCIES = libcuefile libreplaygain
+MUSEPACK_AUTORECONF = YES
+MUSEPACK_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,package/multimedia,musepack))