package/libselinux: fix the selinuxfs mount point
authorAntoine Tenart <antoine.tenart@bootlin.com>
Tue, 6 Oct 2020 15:44:30 +0000 (17:44 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 6 Oct 2020 21:30:51 +0000 (23:30 +0200)
For 9 years the recommended mount point for selinuxfs has been
/sys/fs/selinux, as stated in Linux kernel commit 7a627e3b9a2b:

"""
For selinuxfs, this mount point should be in /sys/fs/selinux/
"""

As other projects follow this convention, not doing so result in
potential issues. One of them is the refpolicy not correctly labelling
and supporting the mount point.

Fix this by using /sys/fs/selinux as of now in Buildroot.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
Reviewed-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libselinux/libselinux.mk

index c96b5a4431096d6c8ccb07c296abe502e5d388d1..8087af539af08c9034b30a24526f1bcfbae5b012 100644 (file)
@@ -70,10 +70,8 @@ define LIBSELINUX_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
                $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(TARGET_DIR) \
                $(LIBSELINUX_MAKE_INSTALL_TARGETS)
-       # Create the selinuxfs mount point
-       if [ ! -d "$(TARGET_DIR)/selinux" ]; then mkdir $(TARGET_DIR)/selinux; fi
        if ! grep -q "selinuxfs" $(TARGET_DIR)/etc/fstab; then \
-               echo "none /selinux selinuxfs noauto 0 0" >> $(TARGET_DIR)/etc/fstab ; fi
+               echo "none /sys/fs/selinux selinuxfs noauto 0 0" >> $(TARGET_DIR)/etc/fstab ; fi
 endef
 
 HOST_LIBSELINUX_DEPENDENCIES = \