package/vlc: add optional dependency to x265
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:16 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 10:00:18 +0000 (12:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index bc20e2946ee69168d8dc8c22eb6d96afbf4109cc..7e496688b98cb3c0210014249e8572b068a1ecaf 100644 (file)
@@ -59,7 +59,6 @@ VLC_CONF_OPTS += \
        --disable-vpx \
        --disable-vsxu \
        --disable-x262 \
-       --disable-x265 \
        --disable-zvbi \
        --enable-run-as-root
 
@@ -416,6 +415,13 @@ else
 VLC_CONF_OPTS += --disable-x264
 endif
 
+ifeq ($(BR2_PACKAGE_X265),y)
+VLC_CONF_OPTS += --enable-x265
+VLC_DEPENDENCIES += x265
+else
+VLC_CONF_OPTS += --disable-x265
+endif
+
 ifeq ($(BR2_PACKAGE_XCB_UTIL_KEYSYMS),y)
 VLC_CONF_OPTS += --enable-xcb
 VLC_DEPENDENCIES += xcb-util-keysyms