package/python-flatbuffers: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Mon, 24 Feb 2020 05:15:48 +0000 (22:15 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 26 Feb 2020 20:55:01 +0000 (21:55 +0100)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-flatbuffers/Config.in [new file with mode: 0644]
package/python-flatbuffers/python-flatbuffers.hash [new file with mode: 0644]
package/python-flatbuffers/python-flatbuffers.mk [new file with mode: 0644]

index 24b68ebe11d86b20b69bdb660fd15db79f648a55..8f6a52b4fb02a4c00d534b7badaddc1a8dec05da 100644 (file)
@@ -1167,6 +1167,7 @@ F:        package/python-async-lru/
 F:     package/python-async-timeout/
 F:     package/python-brotli/
 F:     package/python-cchardet/
+F:     package/python-flatbuffers/
 F:     package/python-frozenlist/
 F:     package/python-janus/
 F:     package/python-logstash/
index 2edcee01a5da139f725838bb96e9d942281716ba..9d83d3948d60e0e5df684650d4a20b29b6f71fbd 100644 (file)
@@ -942,6 +942,7 @@ menu "External python modules"
        source "package/python-flask-jsonrpc/Config.in"
        source "package/python-flask-login/Config.in"
        source "package/python-flask-sqlalchemy/Config.in"
+       source "package/python-flatbuffers/Config.in"
        source "package/python-flup/Config.in"
        source "package/python-frozenlist/Config.in"
        source "package/python-functools32/Config.in"
diff --git a/package/python-flatbuffers/Config.in b/package/python-flatbuffers/Config.in
new file mode 100644 (file)
index 0000000..b24b5aa
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_FLATBUFFERS
+       bool "python-flatbuffers"
+       help
+         The FlatBuffers serialization format for Python.
+
+         https://github.com/google/flatbuffers
diff --git a/package/python-flatbuffers/python-flatbuffers.hash b/package/python-flatbuffers/python-flatbuffers.hash
new file mode 100644 (file)
index 0000000..0cb5437
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/flatbuffers/json
+md5  b5f6c2246f45636dd49d9ff8a00d7f1c  flatbuffers-1.11.tar.gz
+sha256  f24185db54193540e3d684dc98aa7c2d89882341641548ceb36fd2589fef6c4e  flatbuffers-1.11.tar.gz
diff --git a/package/python-flatbuffers/python-flatbuffers.mk b/package/python-flatbuffers/python-flatbuffers.mk
new file mode 100644 (file)
index 0000000..d0374c4
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-flatbuffers
+#
+################################################################################
+
+PYTHON_FLATBUFFERS_VERSION = 1.11
+PYTHON_FLATBUFFERS_SOURCE = flatbuffers-$(PYTHON_FLATBUFFERS_VERSION).tar.gz
+PYTHON_FLATBUFFERS_SITE = https://files.pythonhosted.org/packages/c6/b6/21478b76aa7ccab58da3beb85746b6844dee2112c0cc25b51ec64b46bdbb
+PYTHON_FLATBUFFERS_LICENSE = Apache-2.0
+PYTHON_FLATBUFFERS_SETUP_TYPE = setuptools
+
+$(eval $(python-package))