package/mplayer: add optional libmpeg2 support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:34 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 21:15:50 +0000 (23:15 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index dc2dcb64777b0f70c757b13302058ed621818b51..55cf4210bd8c5fbb44fce51037ee1027d34dbddc 100644 (file)
@@ -151,6 +151,13 @@ ifeq ($(BR2_PACKAGE_LIBASS),y)
 MPLAYER_DEPENDENCIES += libass
 endif
 
+# We intentionally don't pass --enable-libmpeg2 and let autodetection
+# find which library to link with.
+ifeq ($(BR2_PACKAGE_LIBMPEG2),y)
+MPLAYER_DEPENDENCIES += libmpeg2
+MPLAYER_CONF_OPTS += --disable-libmpeg2-internal
+endif
+
 ifeq ($(BR2_PACKAGE_TREMOR),y)
 MPLAYER_DEPENDENCIES += tremor
 MPLAYER_CONF_OPTS += --disable-tremor-internal --enable-tremor