package/altera-stapl: new package
authorJochen Baltes <jochen.baltes@gmail.com>
Fri, 24 Jan 2020 15:16:24 +0000 (15:16 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 14 Sep 2020 21:05:49 +0000 (23:05 +0200)
Alteras Jam STAPL Bytecode Player with 64-bit support.
This is a user-space port of the altera-stapl driver from the linux kernel.
The source released by Altera wasn't 64-bit compatible.
Additionally, the linux version is much cleaner and old cruft was removed.

Signed-off-by: Jochen Baltes <jochen.baltes@gmail.com>
Tested-by: Heiko Thiery <heiko.thiery@gmail.com>
[yann.morin.1998@free.fr: use the latest HEAD of the repository]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/altera-stapl/Config.in [new file with mode: 0644]
package/altera-stapl/altera-stapl.hash [new file with mode: 0644]
package/altera-stapl/altera-stapl.mk [new file with mode: 0644]

index f754a6f34185a5cea0ad15048badde9a3e127e27..d59d538e42cbd3ad21bcc270f784ff10649734ed 100644 (file)
@@ -1315,6 +1315,9 @@ N:        Joao Pinto <jpinto@synopsys.com>
 F:     board/synopsys/vdk/
 F:     configs/snps_aarch64_vdk_defconfig
 
+N:     Jochen Baltes <jochen.baltes@gmail.com>
+F:     package/altera-stapl
+
 N:     Joel Carlson <JoelsonCarl@gmail.com>
 F:     package/c-capnproto/
 F:     package/capnproto/
index 7d6ac1b33c8c2baa727f44d0589c8e1f7ec2f459..1cf36fa28abfa90c4c66ed5781ff7026ebc7d8a4 100644 (file)
@@ -418,6 +418,7 @@ endmenu
        source "package/acpid/Config.in"
        source "package/acpitool/Config.in"
        source "package/aer-inject/Config.in"
+       source "package/altera-stapl/Config.in"
        source "package/am335x-pru-package/Config.in"
        source "package/apcupsd/Config.in"
        source "package/avrdude/Config.in"
diff --git a/package/altera-stapl/Config.in b/package/altera-stapl/Config.in
new file mode 100644 (file)
index 0000000..ff7d23f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_ALTERA_STAPL
+       bool "altera-stapl"
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_8 # libgpiod
+       select BR2_PACKAGE_LIBGPIOD
+       help
+         Altera Jam STAPL Bytecode Player.
+
+         https://github.com/kontron/altera-stapl
diff --git a/package/altera-stapl/altera-stapl.hash b/package/altera-stapl/altera-stapl.hash
new file mode 100644 (file)
index 0000000..29e62b9
--- /dev/null
@@ -0,0 +1,2 @@
+sha256  7f72c234f2fd0181140b6f1f09fc272eae07f20622cec7f26e3b3499ff69825a  altera-stapl-7044a63b7d1a3fc6840cd3130ec984454f1559c0.tar.gz
+sha256  d8c320ffc0030d1b096ae4732b50d2b811cf95e9a9b7377c1127b2563e0a0388  COPYING
diff --git a/package/altera-stapl/altera-stapl.mk b/package/altera-stapl/altera-stapl.mk
new file mode 100644 (file)
index 0000000..189b6c4
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# altera-stapl
+#
+################################################################################
+
+ALTERA_STAPL_VERSION = 7044a63b7d1a3fc6840cd3130ec984454f1559c0
+ALTERA_STAPL_SITE = $(call github,kontron,altera-stapl,$(ALTERA_STAPL_VERSION))
+ALTERA_STAPL_LICENSE = GPLv2+
+ALTERA_STAPL_LICENSE_FILES = COPYING
+ALTERA_STAPL_DEPENDENCIES = libgpiod
+
+define ALTERA_STAPL_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define ALTERA_STAPL_INSTALL_TARGET_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))