e2fsprogs: pass LDCONFIG=true also at install time
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Fri, 18 Nov 2016 15:24:26 +0000 (16:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Dec 2016 14:54:35 +0000 (15:54 +0100)
We correctly set LDCONFIG=true for MAKE_OPTS, but not for the other
steps which don't inherit it, and therefore e2fsprogs tries to use the
host ldconfig during staging and target installation, which causes some
weird error messages at build time (even if they don't abort the build).

Fix that by passing LDCONFIG=true at install time.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/e2fsprogs/e2fsprogs.mk

index b6e79d246b758a64f229192f8be4bec77b4f3e7e..48bb9ec38f9624fe396463de3905b2218048060c 100644 (file)
@@ -63,8 +63,9 @@ ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 E2FSPROGS_CONF_ENV += LIBS=-lintl
 endif
 
-E2FSPROGS_MAKE_OPTS = \
-       LDCONFIG=true
+E2FSPROGS_MAKE_OPTS = LDCONFIG=true
+E2FSPROGS_INSTALL_STAGING_OPTS = LDCONFIG=true
+E2FSPROGS_INSTALL_TARGET_OPTS = LDCONFIG=true
 
 define HOST_E2FSPROGS_INSTALL_CMDS
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install install-libs