package/upx: needs zlib
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 3 Jan 2015 16:25:07 +0000 (17:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Jan 2015 20:40:54 +0000 (21:40 +0100)
Fixes build issues like, observed on a stripped-down build system:
    compress.cpp:32:18: fatal error: zlib.h: No such file or directory
     #include <zlib.h>
                  ^
    compilation terminated.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/upx/upx.mk

index 30bb03bb6a627c02bdca110f62b57411e0d7b067..400d28328d79b53335f355fa19fe43e60dc023a4 100644 (file)
@@ -10,7 +10,7 @@ UPX_SOURCE = upx-$(UPX_VERSION)-src.tar.bz2
 UPX_LICENSE = GPLv2+
 UPX_LICENSE_FILES = COPYING
 
-HOST_UPX_DEPENDENCIES = host-ucl
+HOST_UPX_DEPENDENCIES = host-ucl host-zlib
 
 # We need to specify all, otherwise the default target only prints a message
 # stating to "please choose a target for 'make'"... :-(