package: add jQuery sparkline plugin
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Dec 2011 22:40:11 +0000 (23:40 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Dec 2011 22:40:11 +0000 (23:40 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/jquery-sparkline/Config.in [new file with mode: 0644]
package/jquery-sparkline/jquery-sparkline.mk [new file with mode: 0644]

index 2c15f23a87528153afe09a9a520feb2691bf0136..5520279830145b6c5e4201859772a85e94204e93 100644 (file)
@@ -324,6 +324,7 @@ endif
 
 menu "Javascript"
 source "package/jquery/Config.in"
+source "package/jquery-sparkline/Config.in"
 source "package/jquery-validation/Config.in"
 endmenu
 
diff --git a/package/jquery-sparkline/Config.in b/package/jquery-sparkline/Config.in
new file mode 100644 (file)
index 0000000..ae66364
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_JQUERY_SPARKLINE
+       bool "jQuery-Sparkline"
+       select BR2_PACKAGE_JQUERY
+       help
+         This jQuery plugin generates sparklines (small inline
+         charts) directly in the browser using data supplied either
+         inline in the HTML, or via javascript.
+
+         The plugin is compatible with most modern browsers and has
+         been tested with Firefox 2+, Safari 3+, Opera 9, Google
+         Chrome and Internet Explorer 6, 7 & 8.
+
+         http://www.omnipotent.net/jquery.sparkline/
diff --git a/package/jquery-sparkline/jquery-sparkline.mk b/package/jquery-sparkline/jquery-sparkline.mk
new file mode 100644 (file)
index 0000000..93dddf0
--- /dev/null
@@ -0,0 +1,18 @@
+JQUERY_SPARKLINE_VERSION = 1.6
+JQUERY_SPARKLINE_SITE = http://www.omnipotent.net/jquery.sparkline/$(JQUERY_SPARKLINE_VERSION)
+JQUERY_SPARKLINE_SOURCE = jquery.sparkline.min.js
+
+define JQUERY_SPARKLINE_EXTRACT_CMDS
+       cp $(DL_DIR)/$(JQUERY_SPARKLINE_SOURCE) $(@D)
+endef
+
+define JQUERY_SPARKLINE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/$(JQUERY_SPARKLINE_SOURCE) \
+               $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+define JQUERY_SPARKLINE_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/var/www/jquery.sparkline.js
+endef
+
+$(eval $(call GENTARGETS))