mtd: make sure that dest dir exists before installing mtd files
authorDanomi Mocelopolis <d_mo1234@yahoo.com>
Wed, 2 Nov 2011 11:00:52 +0000 (12:00 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 2 Nov 2011 11:00:52 +0000 (12:00 +0100)
Closes #4387

Signed-off-by: Danomi Mocelopolis <d_mo1234@yahoo.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/mtd/mtd.mk

diff --git a/CHANGES b/CHANGES
index 74ec64facf33583823e39e16fbb8bec17ddce877..0043126bf77b96d432b5a721ff2fcc6cd7346db9 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -33,7 +33,7 @@
        libglib2, libiconv, libmpd, libreplaygain, libroxml,
        libsamplerate, libsndfile, libsoup, libsvgtiny, libtool,
        lighttpd, links, linux-fusion, lite, lrzsz, lsof, lzo, lzop,
-       makedevs, mcookie, mpg123, mpd, mpfr, musepack, mutt,
+       makedevs, mcookie, mpg123, mpd, mpfr, mtd, musepack, mutt,
        mysql_client, ncftp, ncurses, neon, netcat, netsnmp, ntfs-3g,
        ntfsprogs, ntp, openntpd, openssh, openssl, orc, pciutils,
        psmisc, python, qt, quagga, radvd, rpm, rsync, samba, sawman,
@@ -70,6 +70,7 @@
        #4183: Codesourcery toolchain download site has changed
        #4231: libneon.so: undefined reference to `SSL_SESSION_cmp'
        #4381: Add option to lighttpd to enable Lua support
+       #4387: Make sure that dest dir exists before installing mtd files
 
 2011.08, Released August 31th, 2011:
 
index ef876e2d32317c3f8caa8683094b2ef372cf16b6..1b23e8357500d488339483b97039421b3d2b8c3e 100644 (file)
@@ -91,10 +91,10 @@ endef
 
 define MTD_INSTALL_TARGET_CMDS
  for f in $(MTD_TARGETS_y) ; do \
-  install -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+  install -D -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
  done ; \
  for f in $(MTD_TARGETS_UBI_y) ; do \
-  install -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
+  install -D -m 0755 $(@D)/ubi-utils/$$f $(TARGET_DIR)/usr/sbin/$$f ; \
  done
 endef