package/qt5base: disable feature-relocatable
authorPeter Seiderer <ps.report@gmx.net>
Sun, 17 May 2020 10:28:23 +0000 (12:28 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 May 2020 19:24:22 +0000 (21:24 +0200)
Disable feature-relocatable to avoid a path mismatch while searching qml
files and buildroot BR2_ROOTFS_MERGED_USR feature enabled.

As described in [1] with feature-relocatable Qt determines the search
pathes relative to the location of libQt5Core.so, with BR2_ROOTFS_MERGED_USR
enabled found first under the symlink path '/lib' instead of the install
path '/usr/lib' and searches sequentially for qml files under '/qml' instead
of the correct '/usr/qml'.

Fixes:
  - https://bugs.busybox.net/show_bug.cgi?id=12906

[1] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=4ac872639ed0dd3ae6627e05bdda821f7d128500

Reported-by: Joonas Harjumäki <jharjuma@gmail.com>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qt5/qt5base/qt5base.mk

index 97315496b90a631340eb1a920a9b6bf3d775dbae..42d77306cc7f30bcf553239603b9210024542134 100644 (file)
@@ -18,6 +18,9 @@ QT5BASE_INSTALL_STAGING = YES
 #     want to use the Buildroot packaged zlib
 #  * -system-pcre because pcre is mandatory to build Qt, and we
 #    want to use the one packaged in Buildroot
+#  * -no-feature-relocatable to work around path mismatch
+#     while searching qml files and buildroot BR2_ROOTFS_MERGED_USR
+#     feature enabled
 QT5BASE_CONFIGURE_OPTS += \
        -optimized-qmake \
        -no-cups \
@@ -25,7 +28,8 @@ QT5BASE_CONFIGURE_OPTS += \
        -system-zlib \
        -system-pcre \
        -no-pch \
-       -shared
+       -shared \
+       -no-feature-relocatable
 
 # starting from version 5.9.0, -optimize-debug is enabled by default
 # for debug builds and it overrides -O* with -Og which is not what we