gendoc infra: cosmetic fixes
authorSamuel Martin <s.martin49@gmail.com>
Sun, 14 Sep 2014 11:07:35 +0000 (13:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Sep 2014 18:11:02 +0000 (20:11 +0200)
- wrap lines to 80 characters
- fix space/tab mixup

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
[yann.morin.1998@free.fr: tested all but PDF]
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/manual.mk

index 8d401a21d764894683b1b13249360074a1634b40..136f725af723bf795228a0c19dff18e6af42d192 100644 (file)
@@ -70,8 +70,8 @@ $$(O)/docs/$(1)/$(1).$(4): docs/$(1)/$(1).txt \
        $$(Q)mkdir -p $$(@D)/.build
        $$(Q)rsync -au docs/$(1)/*.txt $$(@D)/.build
        $$(Q)a2x $(6) -f $(2) -d book -L -r $$(TOPDIR)/docs/images \
-               -D $$(@D) $$(@D)/.build/$(1).txt \
-               --asciidoc-opts="$$(MANUAL_$(2)_ASCIIDOC_OPTS)"
+               --asciidoc-opts="$$(MANUAL_$(2)_ASCIIDOC_OPTS)" \
+               -D $$(@D) $$(@D)/.build/$(1).txt
        -$$(Q)rm -rf $$(@D)/.build
 endef
 
@@ -84,9 +84,12 @@ endef
 # The variable <DOCUMENT_NAME>_SOURCES defines the dependencies.
 ################################################################################
 define GENDOC
-$(call GENDOC_INNER,$(pkgname),xhtml,html,html,HTML,--xsltproc-opts "--stringparam toc.section.depth 1")
-$(call GENDOC_INNER,$(pkgname),chunked,split-html,chunked,split HTML,--xsltproc-opts "--stringparam toc.section.depth 1")
-$(call GENDOC_INNER,$(pkgname),pdf,pdf,pdf,PDF,--dblatex-opts "-P latex.output.revhistory=0")
+$(call GENDOC_INNER,$(pkgname),xhtml,html,html,HTML,\
+       --xsltproc-opts "--stringparam toc.section.depth 1")
+$(call GENDOC_INNER,$(pkgname),chunked,split-html,chunked,split HTML,\
+       --xsltproc-opts "--stringparam toc.section.depth 1")
+$(call GENDOC_INNER,$(pkgname),pdf,pdf,pdf,PDF,\
+       --dblatex-opts "-P latex.output.revhistory=0")
 $(call GENDOC_INNER,$(pkgname),text,text,text,text)
 $(call GENDOC_INNER,$(pkgname),epub,epub,epub,ePUB)
 clean: $(pkgname)-clean