imx-parser: rename from libfslparser and bump version to 4.0.9
authorAndrew Webster <awebster@arcx.com>
Fri, 10 Jun 2016 18:13:18 +0000 (14:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 20:48:40 +0000 (22:48 +0200)
Changelog:
--Add aac latm parser in parser_libs, support aac latm in mpeg2 parser

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/e2c6f10

Implicitly tested through gstreamer as the 0.10 plugin relies on it:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm

Signed-off-by: Andrew Webster <awebster@arcx.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/Config.in
package/freescale-imx/Config.in
package/freescale-imx/imx-parser/Config.in [new file with mode: 0644]
package/freescale-imx/imx-parser/imx-parser.hash [new file with mode: 0644]
package/freescale-imx/imx-parser/imx-parser.mk [new file with mode: 0644]
package/gstreamer/gst-fsl-plugins/Config.in
package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
package/libfslparser/Config.in [deleted file]
package/libfslparser/libfslparser.hash [deleted file]
package/libfslparser/libfslparser.mk [deleted file]

index e5a568d0f0ea482af2a3404fbef92a12269766dc..12426c9cd89a881bd2ab3301db2b9e99edeb7fc3 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.08"
 
+config BR2_PACKAGE_LIBFSLPARSER
+       bool "libfslparser has been renamed to imx-parser"
+       select BR2_LEGACY
+       select BR2_PACKAGE_IMX_PARSER
+       help
+         The libfslparser has been renamed to match the renamed package.
+
 config BR2_PACKAGE_LIBFSLCODEC
        bool "libfslcodec has been renamed to imx-codec"
        select BR2_LEGACY
index 1f62c19ca6315f0f5d219d6718da0f3f5ee2706b..822367e513d6779022feafdbfc8ecaaa2fbb99c1 100644 (file)
@@ -1102,7 +1102,6 @@ menu "Multimedia"
        source "package/libdvdnav/Config.in"
        source "package/libdvdread/Config.in"
        source "package/libebml/Config.in"
-       source "package/libfslparser/Config.in"
        source "package/libfslvpuwrap/Config.in"
        source "package/libhdhomerun/Config.in"
        source "package/libimxvpuapi/Config.in"
index 052de5ae79606de58af6cf270258b34c08459a8b..868e51cd787d3ef7c05676fd31781e100569e74b 100644 (file)
@@ -52,6 +52,7 @@ config BR2_PACKAGE_FREESCALE_IMX_HAS_VPU
 source "package/freescale-imx/imx-codec/Config.in"
 source "package/freescale-imx/imx-kobs/Config.in"
 source "package/freescale-imx/imx-lib/Config.in"
+source "package/freescale-imx/imx-parser/Config.in"
 source "package/freescale-imx/imx-uuc/Config.in"
 source "package/freescale-imx/imx-vpu/Config.in"
 source "package/freescale-imx/firmware-imx/Config.in"
diff --git a/package/freescale-imx/imx-parser/Config.in b/package/freescale-imx/imx-parser/Config.in
new file mode 100644 (file)
index 0000000..526f066
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_IMX_PARSER
+       bool "imx-parser"
+       depends on BR2_arm # Only relevant for i.MX
+       help
+         Binary parser libraries for the NXP i.MX SoCs.
+
+         This library is provided by NXP as-is and doesn't have
+         an upstream.
diff --git a/package/freescale-imx/imx-parser/imx-parser.hash b/package/freescale-imx/imx-parser/imx-parser.hash
new file mode 100644 (file)
index 0000000..2193c66
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed
+sha256 1bec0101843db2e95d61e3dbe9e35172d874e54be19cc5d8bf72a735d5e3236f  imx-parser-4.0.9.bin
diff --git a/package/freescale-imx/imx-parser/imx-parser.mk b/package/freescale-imx/imx-parser/imx-parser.mk
new file mode 100644 (file)
index 0000000..a207d6e
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# imx-parser
+#
+################################################################################
+
+IMX_PARSER_VERSION = 4.0.9
+IMX_PARSER_SITE = $(FREESCALE_IMX_SITE)
+IMX_PARSER_SOURCE = imx-parser-$(IMX_PARSER_VERSION).bin
+IMX_PARSER_INSTALL_STAGING = YES
+
+IMX_PARSER_LICENSE = NXP Semiconductor Software License Agreement
+IMX_PARSER_LICENSE_FILES = EULA COPYING
+IMX_PARSER_REDISTRIBUTE = NO
+
+define IMX_PARSER_EXTRACT_CMDS
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_PARSER_SOURCE))
+endef
+
+# The Makefile installs several versions of the libraries, but we only
+# need one of them, depending on the platform.
+
+$(eval $(autotools-package))
index 8c82a4a02a000f499e6f620d245c92da19bce086..38c8a477b204f463b469e84743e740be8edb00d5 100644 (file)
@@ -13,7 +13,7 @@ config BR2_PACKAGE_GST_FSL_PLUGINS
        select BR2_PACKAGE_GST_PLUGINS_BASE
        select BR2_PACKAGE_LIBFSLVPUWRAP if BR2_PACKAGE_FREESCALE_IMX_HAS_VPU
        select BR2_PACKAGE_IMX_LIB
-       select BR2_PACKAGE_LIBFSLPARSER
+       select BR2_PACKAGE_IMX_PARSER
        select BR2_PACKAGE_IMX_CODEC
        select BR2_PACKAGE_FREESCALE_IMX
        help
index 50732bffeed6123dbf4f7b1094ea0b17700366c8..8db8d1b562615e84a6283f8b279eeefdd957a3f6 100644 (file)
@@ -16,7 +16,7 @@ GST_FSL_PLUGINS_INSTALL_STAGING = YES
 GST_FSL_PLUGINS_AUTORECONF = YES
 
 GST_FSL_PLUGINS_DEPENDENCIES += host-pkgconf gstreamer gst-plugins-base \
-       imx-lib libfslparser imx-codec
+       imx-lib imx-parser imx-codec
 
 ifeq ($(BR2_PACKAGE_FREESCALE_IMX_HAS_VPU),y)
 GST_FSL_PLUGINS_DEPENDENCIES += libfslvpuwrap
diff --git a/package/libfslparser/Config.in b/package/libfslparser/Config.in
deleted file mode 100644 (file)
index e3ab980..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_LIBFSLPARSER
-       bool "libfslparser"
-       depends on BR2_arm # Only relevant for i.MX
-       help
-         Binary parser libraries for the Freescale i.MX SoCs.
-
-         This library is provided by Freescale as-is and doesn't have
-         an upstream.
diff --git a/package/libfslparser/libfslparser.hash b/package/libfslparser/libfslparser.hash
deleted file mode 100644 (file)
index c49345f..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# locally computed
-sha256 a04621783c84a9776216caff9563c7f840fddd584b0b2d27738d6ca6d2c77f32  libfslparser-4.0.8.bin
diff --git a/package/libfslparser/libfslparser.mk b/package/libfslparser/libfslparser.mk
deleted file mode 100644 (file)
index 44e6039..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-################################################################################
-#
-# libfslparser
-#
-################################################################################
-
-LIBFSLPARSER_VERSION = 4.0.8
-LIBFSLPARSER_SITE = $(FREESCALE_IMX_SITE)
-LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
-LIBFSLPARSER_INSTALL_STAGING = YES
-
-LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
-LIBFSLPARSER_LICENSE_FILES = EULA COPYING
-LIBFSLPARSER_REDISTRIBUTE = NO
-
-define LIBFSLPARSER_EXTRACT_CMDS
-       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(LIBFSLPARSER_SOURCE))
-endef
-
-# The Makefile installs several versions of the libraries, but we only
-# need one of them, depending on the platform.
-
-$(eval $(autotools-package))