mpd: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:19:01 +0000 (15:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:42:44 +0000 (00:42 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

[Peter: use install -m as noted by Yann]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/mpd.mk

index 1eedcbcb3cac115c1b8bcc5ca2ac7329cac3f23f..c80de41602efb70cd2aa1699f53a748248c2afe1 100644 (file)
@@ -228,10 +228,7 @@ MPD_CONF_OPTS += --disable-wavpack
 endif
 
 define MPD_INSTALL_EXTRA_FILES
-       @if [ ! -f $(TARGET_DIR)/etc/mpd.conf ]; then \
-               $(INSTALL) -D package/mpd/mpd.conf \
-                       $(TARGET_DIR)/etc/mpd.conf; \
-       fi
+       $(INSTALL) -m 0644 -D package/mpd/mpd.conf $(TARGET_DIR)/etc/mpd.conf
 endef
 
 MPD_POST_INSTALL_TARGET_HOOKS += MPD_INSTALL_EXTRA_FILES