ffmpeg: disable freetype support on microblaze/glibc
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Jan 2015 07:18:30 +0000 (08:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Jan 2015 07:29:05 +0000 (08:29 +0100)
Fixes http://autobuild.buildroot.net/results/6dd/6ddefaf001b9275ee073effbd6eb07be9f43e24d/

While it does provide fenv.h, it doesn't support the needed exceptions so
disable it.

Reported-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 16f53be6998e2bdc802b4afbf7da5de39fc99ebb..f9c1d94820a7a0a54ff302aaa63c4b13227ff9b2 100644 (file)
@@ -234,8 +234,9 @@ FFMPEG_CONF_OPTS += --disable-libvpx
 endif
 
 # ffmpeg freetype support require fenv.h which is only
-# available/working on glibc
-ifeq ($(BR2_PACKAGE_FREETYPE)$(BR2_TOOLCHAIN_USES_GLIBC),yy)
+# available/working on glibc.
+# The microblaze variant doesn't provide the needed exceptions
+ifeq ($(BR2_PACKAGE_FREETYPE)$(BR2_TOOLCHAIN_USES_GLIBC)x$(BR2_microblaze),yyx)
 FFMPEG_CONF_OPTS += --enable-libfreetype
 FFMPEG_DEPENDENCIES += freetype
 else