systemd: fix path for kmod in service files
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Thu, 3 Jul 2014 16:57:36 +0000 (18:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 21:24:00 +0000 (23:24 +0200)
The path for kmod used in kmod-static-nodes.service is the one found by
the ./configure script, which ends up being the path to the host kmod
program.

This patch forces the path to the target kmod program.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index 95e72148f87ff923a39e8faed57edfe6f909539e..f7fbf79a54c4ca02c7637ecbfc874eb38e2688eb 100644 (file)
@@ -50,6 +50,10 @@ SYSTEMD_CONF_OPT += \
        --disable-dbus \
        --without-python
 
+# Override path to kmod, used in kmod-static-nodes.service
+SYSTEMD_CONF_ENV = \
+       ac_cv_path_KMOD=/usr/bin/kmod
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_COMPAT),y)
 SYSTEMD_CONF_OPT += --enable-compat-libs
 else