e2fsprogs: do not use ldconfig when building the host variant
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 31 Aug 2018 21:12:39 +0000 (23:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 9 Sep 2018 13:21:59 +0000 (15:21 +0200)
Since commit 93acaa5a573865afc7a8c0912a7037965eb845a6 ("e2fsprogs:
build shared library for the host"), we are building shared libraries
in host-e2fsprogs instead of static libraries. A consequence of this
is that the e2fsprogs build system tries to run ldconfig on the host,
which fails when running as non-root:

/usr/sbin/ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied
make[3]: [Makefile:441: install-shlibs] Error 1 (ignored)

Tell the configure script to use "true" as ldconfig in order to avoid
this problem.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/e2fsprogs/e2fsprogs.mk

index 2c5098883a3e40757da67d7c85c9e10be04e697e..659df8062e6ddb41ce0d1ff6439726b6e215c5c9 100644 (file)
@@ -70,7 +70,8 @@ E2FSPROGS_CONF_ENV += BUILD_CFLAGS="-DHAVE_SYS_STAT_H"
 # it doesn't provide definitions expected by e2fsprogs support lib.
 HOST_E2FSPROGS_CONF_ENV += \
        ac_cv_header_magic_h=no \
-       ac_cv_lib_magic_magic_file=no
+       ac_cv_lib_magic_magic_file=no \
+       ac_cv_path_LDCONFIG=true
 
 E2FSPROGS_MAKE_OPTS = LDCONFIG=true