fs: change the way the device table is configured
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 01:26:16 +0000 (03:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 02:36:23 +0000 (04:36 +0200)
Until now, the location of the device table was specified by a
variable in board Makefiles. Unfortunately, this variable is not
accessible from fs/common.mk, since the target/ code is included
*after* fs/common.mk.

Anyway, the general idea is to move away from these boards Makefile,
and provide configuration option for things like the device table
location.

Therefore, this patch adds a BR2_ROOTFS_DEVICE_TABLE option which
allows to specify which device table should be used.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/Config.in
fs/common.mk

index f885c52e7c361f79b620ad92ab6ead4c3b416f34..6865eeaff78f1e0c2cba0352c2d6135e26900250 100644 (file)
@@ -15,6 +15,14 @@ config BR2_ROOTFS_POST_BUILD_SCRIPT
          only argument. Make sure the exit code of that script is 0,
          otherwise make will stop after calling it.
 
+config BR2_ROOTFS_DEVICE_TABLE
+       string "Path to the device table"
+       default "target/generic/device_table.txt"
+       help
+         Specify the location of a device table, that will be passed
+         to the makedevs utility to create all the special device
+         files in the target filesystem.
+
 source "fs/cramfs/Config.in"
 source "fs/cloop/Config.in"
 source "fs/ext2/Config.in"
index fa6afd94d0f477f17c7813372528672a092b08b8..cc94eb4ef22fc0a02e06449dea3d9740fc09d1d5 100644 (file)
@@ -28,6 +28,7 @@
 # macro will automatically generate a compressed filesystem image.
 
 FAKEROOT_SCRIPT = $(BUILD_DIR)/_fakeroot.fs
+ROOTFS_DEVICE_TABLE = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE))
 
 define ROOTFS_TARGET_INTERNAL
 
@@ -38,8 +39,8 @@ $(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot makedevs
        touch $(BUILD_DIR)/.fakeroot.00000
        cat $(BUILD_DIR)/.fakeroot* > $(FAKEROOT_SCRIPT)
        echo "chown -R 0:0 $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
-ifneq ($(TARGET_DEVICE_TABLE),)
-       echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
+ifneq ($(ROOTFS_DEVICE_TABLE),)
+       echo "$(HOST_DIR)/usr/bin/makedevs -d $(ROOTFS_DEVICE_TABLE) $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
 endif
        echo "$(ROOTFS_$(2)_CMD)" >> $(FAKEROOT_SCRIPT)
        chmod a+x $(FAKEROOT_SCRIPT)