package/mplayer: add optional dependencies to libgl, libvpx and opus
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 17 Jan 2016 21:18:20 +0000 (22:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Mar 2016 20:19:39 +0000 (21:19 +0100)
Mplayer links to these packages when present:

output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/mplayer | grep NEEDED | grep "opus\|vpx\|GL"
 0x0000000000000001 (NEEDED)             Shared library: [libopus.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libvpx.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libGL.so.1]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 3051afab17cbe72a48a4f739c9976f5a56b4910e..2082f2519061d87c2f6c038e14c59882771ac85d 100644 (file)
@@ -231,9 +231,12 @@ MPLAYER_CONF_OPTS += --disable-liblzo
 endif
 
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_BZIP2),bzip2)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_HAS_LIBGL),libgl)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBTHEORA),libtheora)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBPNG),libpng)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBVPX),libvpx)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_OPUS),opus)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBX11),xlib_libX11)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBXEXT),xlib_libXext)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBXINERAMA),xlib_libXinerama)