package/qpid-proton: fix build without C++
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 2 Apr 2021 16:33:43 +0000 (18:33 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 2 Apr 2021 21:50:16 +0000 (23:50 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/05f344151100219c159ca4d466a453df96bf07fa

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - move code in thread condition, to avoid setting -DBUILD_CPP twice
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qpid-proton/qpid-proton.mk

index c1bcbd0d1ad6e796ac46543e575049134f093b58..4e03357261a7be697a7b67cf36af8df07e397236 100644 (file)
@@ -33,7 +33,13 @@ QPID_PROTON_CONF_OPTS = \
 
 # epoll proactor unconditionally uses pthread and cpp (C++) bindings
 # unconditionally use proactor
-ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+QPID_PROTON_CONF_OPTS += -DBUILD_CPP=ON
+else
+QPID_PROTON_CONF_OPTS += -DBUILD_CPP=OFF
+endif
+else
 QPID_PROTON_CONF_OPTS += \
        -DBUILD_CPP=OFF \
        -DPROACTOR=none