package/rpm: add gettext dependency
authorRomain Naour <romain.naour@openwide.fr>
Sun, 18 Jan 2015 19:53:07 +0000 (20:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Feb 2015 21:54:10 +0000 (22:54 +0100)
rpm check for libintl library if BR2_NEEDS_GETTEXT_IF_LOCALE is set.

checking for GNU gettext in libintl... yes
checking whether to use NLS... yes
checking where the gettext function comes from... external libintl
checking how to link with libintl... -lintl

But the dependency on gettext package is missing to ensures
reproducible builds.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpm/Config.in
package/rpm/rpm.mk

index 379b15b427c95d195456ca3be404e68607b2ed46..5ec4167fd380c00ff35bbe9c975d7fe97992742e 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_RPM
        depends on BR2_TOOLCHAIN_HAS_THREADS # beecrypt
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_BEECRYPT
+       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_NEON
        select BR2_PACKAGE_NEON_SSL
        select BR2_PACKAGE_NEON_XML
index c4215b5bc685cfd507c9025a5336f19d604273c4..74f5b888e7eeba1f6301c7f333ab298e52d330b0 100644 (file)
@@ -26,6 +26,10 @@ RPM_CONF_OPTS = \
        --with-libbeecrypt=$(STAGING_DIR) \
        --with-popt=$(STAGING_DIR)
 
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+RPM_DEPENDENCIES += gettext
+endif
+
 ifeq ($(BR2_PACKAGE_PCRE),y)
 RPM_DEPENDENCIES += pcre
 RPM_CONF_OPTS += --with-pcre=external