coreutils: get the uptime program to work
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Sep 2014 20:44:04 +0000 (22:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Sep 2014 21:53:15 +0000 (23:53 +0200)
coreutils configure script needs to know whether /proc/uptime is
available, but this is not possible in a cross-compilation
context. This leads to an uptime program that fails to work on the
target, as it has been compiled without /proc/uptime reading support.

This commit fixes that by telling coreutils at configure time that
/proc/uptime will be available on the target (which seems to be a
reasonable assumption on Linux systems).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/coreutils/coreutils.mk

index 07a13477894f41b36f7115bb1d1c16488e23fe21..e6af7e297bd6553c9a773282a0db12b6fad8220a 100644 (file)
@@ -57,6 +57,7 @@ COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
                gl_cv_func_working_mkstemp=yes \
                gl_cv_func_working_utimes=yes \
                gl_getline_needs_run_time_check=no \
+               gl_cv_have_proc_uptime=yes \
                utils_cv_localtime_cache=no \
                PERL=missing