bmon: make ncurses dependency optional
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Jun 2011 07:15:42 +0000 (09:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Jun 2011 08:58:55 +0000 (10:58 +0200)
bmon can be built without ncurses support (needs a small patch though),
so don't enforce it in kconfig.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bmon/Config.in
package/bmon/bmon-curses.patch [new file with mode: 0644]
package/bmon/bmon.mk

index 667788bc0a16ec544f0352c8e84dfe85b6e1b398..96921180052a1d0de9a794624d193d5b1e75d347 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_BMON
        bool "bmon"
        depends on BR2_INET_IPV6
-       select BR2_PACKAGE_NCURSES
        help
          Linux bandwidth monitor
 
diff --git a/package/bmon/bmon-curses.patch b/package/bmon/bmon-curses.patch
new file mode 100644 (file)
index 0000000..0eb164e
--- /dev/null
@@ -0,0 +1,26 @@
+[PATCH] fix build without curses
+
+bmon supports a --disable-curses configure option, but still #error
+out if curses wasn't detected, even though the rest of the code is
+written to work without curses support.
+
+Fix it by removing the bogus #error line.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ include/bmon/config.h |    2 --
+ 1 file changed, 2 deletions(-)
+
+Index: bmon-2.1.0/include/bmon/config.h
+===================================================================
+--- bmon-2.1.0.orig/include/bmon/config.h
++++ bmon-2.1.0/include/bmon/config.h
+@@ -118,8 +118,6 @@
+ #  endif /* !HAVE_CURSES */
+ #elif defined HAVE_CURSES
+ #  include <curses.h>
+-#else
+-#  error "*** ERROR: Neither ncurses nor curses is present on your system. ***"
+ #endif /* HAVE_[N]CURSES */
+ #if defined HAVE_RRD
index 97d4b0231e5c866bbec3fef3d1890b88c6a611f9..aa097fbe02d31c317c3168c112cd6386de6d6f61 100644 (file)
@@ -7,7 +7,12 @@
 BMON_VERSION = 2.1.0
 BMON_SOURCE = bmon-$(BMON_VERSION).tar.gz
 BMON_SITE = http://distfiles.gentoo.org/distfiles
-BMON_DEPENDENCIES = ncurses
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+BMON_DEPENDENCIES += ncurses
+else
+BMON_CONF_OPT += --disable-curses
+endif
 
 ifneq ($(BR2_PREFER_STATIC_LIB),y)
 # link dynamically unless explicitly requested otherwise