package/nodejs: use shared c-ares
authorMartin Bark <martin@barkynet.com>
Tue, 18 Jul 2017 11:45:41 +0000 (12:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Jul 2017 19:58:12 +0000 (21:58 +0200)
nodejs requires c-ares and by default will use an internal copy
bundled with the release.  Change to using a shared c-ares library.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nodejs/Config.in
package/nodejs/nodejs.mk

index 3022f9c63a623dd2103cade55b04e746f1d545fa..f90ca2b3fbae1ce6cd8d05cc6ebc2d23c226b30a 100644 (file)
@@ -24,6 +24,7 @@ config BR2_PACKAGE_NODEJS
        # uses dlopen(). On ARMv5, we could technically support static
        # linking, but that's too much of a corner case to support it.
        depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_C_ARES
        select BR2_PACKAGE_ZLIB
        help
          Event-driven I/O server-side JavaScript environment based on V8.
index 43c5ff35b4f5c06b6285f43e8e129854baa96ab4..5bf8889ea9169360e1811ae1a6ef521faf6bb463 100644 (file)
@@ -7,7 +7,7 @@
 NODEJS_VERSION = 8.1.4
 NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
 NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
-NODEJS_DEPENDENCIES = host-python host-nodejs zlib \
+NODEJS_DEPENDENCIES = host-python host-nodejs c-ares zlib \
        $(call qstrip,$(BR2_PACKAGE_NODEJS_MODULES_ADDITIONAL_DEPS))
 HOST_NODEJS_DEPENDENCIES = host-python host-zlib
 NODEJS_LICENSE = MIT (core code); MIT, Apache and BSD family licenses (Bundled components)
@@ -16,6 +16,7 @@ NODEJS_LICENSE_FILES = LICENSE
 NODEJS_CONF_OPTS = \
        --without-snapshot \
        --shared-zlib \
+       --shared-cares \
        --without-dtrace \
        --without-etw \
        --dest-os=linux