package/lm-sensors: always pass TARGET_CONFIGURE_OPTS
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 13 Jul 2020 09:37:29 +0000 (11:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Jul 2020 21:10:47 +0000 (23:10 +0200)
lm-sensors dropped MACHINE variable since version 3.6.0 and
https://github.com/lm-sensors/lm-sensors/commit/0863eff8fa1d32797e3aec19672878aff893b0ae
instead it uses $(CC) -dumpmachine to guess the architecture

However, as $(TARGET_CONFIGURE_OPTS) is only passed to build step and
not to install steps, this result in some binaries being built for the
host during install step and raising a build failure on some autobuilders

Fixes:
 - http://autobuild.buildroot.org/results/0180989afdd9272ecd5010a787931e0b10a6cdcf

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lm-sensors/lm-sensors.mk

index a69ca6e2bf1cfccb5bcd738c533d3686a7033c6b..8975efaffaab8db84afa832fee8eed46f84a508b 100644 (file)
@@ -20,7 +20,7 @@ LM_SENSORS_BINS_$(BR2_PACKAGE_LM_SENSORS_PWMCONFIG) += sbin/pwmconfig
 LM_SENSORS_BINS_$(BR2_PACKAGE_LM_SENSORS_SENSORS_DETECT) += sbin/sensors-detect
 
 LM_SENSORS_MAKE_OPTS = \
-       MACHINE=$(KERNEL_ARCH) \
+       $(TARGET_CONFIGURE_OPTS) \
        PREFIX=/usr
 
 ifeq ($(BR2_STATIC_LIBS),y)
@@ -36,7 +36,7 @@ LM_SENSORS_MAKE_OPTS += BUILD_STATIC_LIB=1
 endif
 
 define LM_SENSORS_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) $(LM_SENSORS_MAKE_OPTS) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) $(LM_SENSORS_MAKE_OPTS) -C $(@D)
 endef
 
 define LM_SENSORS_INSTALL_STAGING_CMDS