httping: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:48:15 +0000 (22:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:26 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/httping/Config.in
package/httping/httping.mk

index 6564415997149aff8f4e550e98acb51d85cd00f6..07ff1020810c4c96f1a3cbe8977592f383d25c1a 100644 (file)
@@ -4,7 +4,6 @@ comment "httping needs a toolchain w/ wchar"
 config BR2_PACKAGE_HTTPING
        bool "httping"
        depends on BR2_USE_WCHAR
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        help
          Httping is like 'ping' but for http-requests.
          Give it an url, and it'll show you how long it takes to connect,
index e1c686f1b913bdcc3dfa6a7bfda8206be4e52380..649c6439450b13af63f1b0043d36511725b168f8 100644 (file)
@@ -10,10 +10,10 @@ HTTPING_SITE = http://www.vanheusden.com/httping
 HTTPING_LICENSE = GPL-2.0
 HTTPING_LICENSE_FILES = license.txt
 HTTPING_LDFLAGS = $(TARGET_LDFLAGS) \
-       $(if $(BR2_NEEDS_GETTEXT),-lintl) \
+       $(TARGET_NLS_LIBS) \
        $(if $(BR2_PACKAGE_LIBICONV),-liconv)
-HTTPING_DEPENDENCIES = host-gettext \
-       $(if $(BR2_NEEDS_GETTEXT),gettext) \
+HTTPING_DEPENDENCIES = \
+       $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
        $(if $(BR2_PACKAGE_NCURSES_WCHAR),ncurses) \
        $(if $(BR2_PACKAGE_OPENSSL),openssl) \