package/gcc: remove BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Oct 2018 11:54:15 +0000 (13:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Oct 2018 14:26:59 +0000 (16:26 +0200)
Since commit 8f8e9162fae5fdc1788dcf33f02b20ddaa5e6846 ("package/gcc:
do not mourn avr32 for too long..."), in which we dropped AVR32
support, the BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE is always
'y'. Therefore, it is totally useless to keep this option around, and
this commit removes it, making the corresponding code unconditional
along the way.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gcc/Config.in.host
package/gcc/gcc-initial/gcc-initial.mk
package/gcc/gcc.mk

index 3bf87fe597f1be9af1c7db5f6cd9cde73c0f4cc3..1d4e946f558dc3759daa143477068ddcb01d6896 100644 (file)
@@ -72,10 +72,6 @@ config BR2_GCC_VERSION_8_X
 
 endchoice
 
-config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
-       bool
-       default y
-
 # libcilkrts was introduced in gcc 4.9 (oldest gcc version we
 # support), and removed in gcc 8.x
 config BR2_GCC_SUPPORTS_LIBCILKRTS
index 9b20eb18f958d55a20bb078964e2c25bd95a8c09..d5d925a3d9286bbfbfb919a4d63e5f7aae141789 100644 (file)
@@ -45,13 +45,8 @@ HOST_GCC_INITIAL_CONF_OPTS = \
 HOST_GCC_INITIAL_CONF_ENV = \
        $(HOST_GCC_COMMON_CONF_ENV)
 
-HOST_GCC_INITIAL_MAKE_OPTS = $(HOST_GCC_COMMON_MAKE_OPTS) all-gcc
-HOST_GCC_INITIAL_INSTALL_OPTS = install-gcc
-
-ifeq ($(BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE),y)
-HOST_GCC_INITIAL_MAKE_OPTS += all-target-libgcc
-HOST_GCC_INITIAL_INSTALL_OPTS += install-target-libgcc
-endif
+HOST_GCC_INITIAL_MAKE_OPTS = $(HOST_GCC_COMMON_MAKE_OPTS) all-gcc all-target-libgcc
+HOST_GCC_INITIAL_INSTALL_OPTS = install-gcc install-target-libgcc
 
 HOST_GCC_INITIAL_TOOLCHAIN_WRAPPER_ARGS += $(HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS)
 HOST_GCC_INITIAL_POST_BUILD_HOOKS += TOOLCHAIN_WRAPPER_BUILD
index 9e9069ce0e276cf3eaf1a9cc70b7ea53c3401452..8b0fec74f1e54ae41962008de6a1339f4a5e341f 100644 (file)
@@ -98,6 +98,7 @@ HOST_GCC_COMMON_CONF_OPTS = \
        --with-gnu-ld \
        --disable-libssp \
        --disable-multilib \
+       --disable-decimal-float \
        --with-gmp=$(HOST_DIR) \
        --with-mpc=$(HOST_DIR) \
        --with-mpfr=$(HOST_DIR) \
@@ -195,10 +196,6 @@ HOST_GCC_COMMON_CONF_OPTS += --with-float=soft
 endif
 endif
 
-ifeq ($(BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE),y)
-HOST_GCC_COMMON_CONF_OPTS += --disable-decimal-float
-endif
-
 # Determine arch/tune/abi/cpu options
 ifneq ($(GCC_TARGET_ARCH),)
 HOST_GCC_COMMON_CONF_OPTS += --with-arch="$(GCC_TARGET_ARCH)"