boost: add fiber module
authorAdam Duskett <aduskett@gmail.com>
Mon, 23 Oct 2017 18:48:24 +0000 (14:48 -0400)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 23 Oct 2017 19:51:37 +0000 (21:51 +0200)
This module requires NPTL. Without support for the module, it is built
unconditionally, which was causing the following build errors:
http://autobuild.buildroot.net/results/029/0298038fc126d15733d81c54e0bb7cb00be48b92/build-end.log
http://autobuild.buildroot.net/results/6f3/6f3a218c47204e431100799482a3ed0ec159fa15/build-end.log
http://autobuild.buildroot.net/results/63e/63e5569a90d3ace97cb6102509cbd04aeab6f5f7/build-end.log

Signed-off-by: Adam Duskett <aduskett@gmail.com>
[Arnout: add empty line in Config.in, reword commit message]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/boost/Config.in
package/boost/boost.mk

index 3b3c89b8c13b8b600c51c100de3ee390a40811d3..37a7e7339fb03287677eb624b742e6c009fdd1fa 100644 (file)
@@ -79,6 +79,13 @@ config BR2_PACKAGE_BOOST_DATE_TIME
 config BR2_PACKAGE_BOOST_EXCEPTION
        bool "boost-exception"
 
+config BR2_PACKAGE_BOOST_FIBER
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
+       bool "boost-fiber"
+
+comment "boost-fiber needs a toolchain w/ NPTL"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL
+
 config BR2_PACKAGE_BOOST_FILESYSTEM
        bool "boost-filesystem"
 
index 598ffbe10e7a0b7ada80863c2131e57c4c230df5..0fd6c4d0dedcf9fcfae06eb228b2ddb58b974cce 100644 (file)
@@ -26,6 +26,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE),,coroutine)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,fiber)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,filesystem)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH),,graph)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH_PARALLEL),,graph_parallel)