package/libsigrok: fix libftdi support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 28 Oct 2019 11:24:11 +0000 (12:24 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 28 Oct 2019 22:37:58 +0000 (23:37 +0100)
libsigrok optionally depends on libftdi1, not libftdi. This was already
the case for a long time, but until the recent commit 01b30e5d69f, all
the configure options were wrong so it would use the automatic check for
availability of libftdi1. Now we pass the --with-libftdi option
explicitly, configure will fail if libftdi1 is not available.

Fixes:
 - http://autobuild.buildroot.net/results/ec1f9f57944139b24738c1be529c4fc4b128a516

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libsigrok/libsigrok.mk

index c65d63eb2a87e162805646b02d4489e2b5830ad1..aa79191e944911a7ce90ac30738edee4e099ab04 100644 (file)
@@ -19,9 +19,9 @@ else
 LIBSIGROK_CONF_OPTS += --without-libserialport
 endif
 
-ifeq ($(BR2_PACKAGE_LIBFTDI),y)
+ifeq ($(BR2_PACKAGE_LIBFTDI1),y)
 LIBSIGROK_CONF_OPTS += --with-libftdi
-LIBSIGROK_DEPENDENCIES += libftdi
+LIBSIGROK_DEPENDENCIES += libftdi1
 else
 LIBSIGROK_CONF_OPTS += --without-libftdi
 endif