sdl_mixer: run CONFIG_UPDATE on correct directory
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jul 2008 08:53:18 +0000 (08:53 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jul 2008 08:53:18 +0000 (08:53 -0000)
The Makefile tried to update config.guess and config.sub in the wrong
directories, this patch updates the correct scripts making it possible to
compile on new systems.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/sdl_mixer/sdl_mixer.mk

index 3c88eae263533d8693bf760e4c4a47d4bb6fd548..522e05d42ea554007682e9cbace4a452d271cfda 100644 (file)
@@ -16,7 +16,7 @@ sdl_mixer-source: $(DL_DIR)/$(SDL_MIXER_SOURCE)
 
 $(SDL_MIXER_DIR)/.unpacked: $(DL_DIR)/$(SDL_MIXER_SOURCE)
        $(SDL_MIXER_CAT) $(DL_DIR)/$(SDL_MIXER_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(CONFIG_UPDATE) $(SDL_MIXER_DIR)
+       $(CONFIG_UPDATE) $(SDL_MIXER_DIR)/build-scripts
        touch $@
 
 $(SDL_MIXER_DIR)/.configured: $(SDL_MIXER_DIR)/.unpacked $(STAGING_DIR)/usr/lib/libSDL.so