automake: use whenever possible the ACLOCAL_DIR variable
authorFabio Porcedda <fabio.porcedda@gmail.com>
Sun, 1 Feb 2015 16:51:40 +0000 (17:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 23:02:13 +0000 (00:02 +0100)
Use the ACLOCAL_DIR in the GTK_DOC_M4_INSTALL hook.

Move the ACLOCAL_DIR definition at the beginning so the definition is
ahead the utilization.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/automake/automake.mk

index 5021b494b9c1935268b4c3f9de111c7c8e3aa895..264cbadeda9250af85e830b788b53c895a342443 100644 (file)
@@ -12,8 +12,11 @@ AUTOMAKE_LICENSE_FILES = COPYING
 
 HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
 
+ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
+
 define GTK_DOC_M4_INSTALL
-       $(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 $(HOST_DIR)/usr/share/aclocal/gtk-doc.m4
+       $(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 \
+               $(ACLOCAL_DIR)/gtk-doc.m4
 endef
 
 # ensure staging aclocal dir exists
@@ -28,5 +31,4 @@ $(eval $(host-autotools-package))
 
 # variables used by other packages
 AUTOMAKE = $(HOST_DIR)/usr/bin/automake
-ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
 ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)